Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Unknown option -no-webkit?



  • Is there a reason I get "Unknown option -no-webkit" even thou -no-webkit is listed in the configure options when trying to build Qt5?



  • The "-no-webkit" option was removed from configure, maybe the configure --help still need to be updated.

    If you initialized the repo with the qtwebkit submodule, "cd qtwebkit && make" might work.



  • So the option to omit the N1 build breaker was removed? That doesn't sound very smart...



  • If you do not want to build QtWebKit at all, use the --no-webkit argument of the init-repository script and you are done.



  • Ok, will give it another go, thanks a lot.



  • never mind that... found the problem



  • What was the problem?

    Let's help our friends from the future, when their favorite search engine brings them to this thread =P



  • The problem, for some reason was that the double dash is displayed as one single, longer dash. When I copied and pasted it into the dos prompt it didn't work, later I opened the perl script and saw it is two dashes and used that instead and that did the trick. So the option is really:

    @--no-webkit@



  • init-repository script what is this?
    unable to make ./configure -no-webkit work.
    How to turn off webkit?


  • Moderators

    [quote author="peteb6" date="1368537661"]init-repository script what is this?
    unable to make ./configure -no-webkit work.
    How to turn off webkit?[/quote]init-repository is a Perl script for automatically downloading and configuring Qt's git repositiories. See http://qt-project.org/wiki/Building-Qt-5-from-Git . The posts above say that the solution is to use a double-dash.

    Edit: That's for init-repository, not configure

    Or, you can just delete the "webkit" folder before you run configure.



  • double dash doesn't work.

    I've tried deleting folder will post later if that worked



  • @-skip qtwebkit@

    works for QT 5.2.1



  • neither :

    perl init-repository --no-webkit
    

    nor :

    perl init-repository -skip qtwebkit
    

    worked :(
    however

    perl init-repository --module-subset=default,-qtwebkit,-qtwebkit-examples
    

    seems it did the job, webkit is no more during git submodule init,
    someone need to update the docs since they are wrong !!! someone??


  • Lifetime Qt Champion

    Hi,

    What documentation are you talking about ?

    Please note that this thread is 5 years old, a lot happened in between including removal of the QtWebKit from the pre-built binaries after deprecation.


Log in to reply