Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Cannot select the kit I want for a project in qtcreator



  • Good morning to you all,

    I've defined two kits for my project. The "desktop" one, and the "ArmHF" one for my embedded software developments.

    I am not able to select the kit I want for my projects. There are two projects (named PFD2020 and ExxoMaj), I can only select "desktop" for one of them and I can only select "ArmHF" for the other one.

    However, both are embedded software expected to run on my Linux device. And therefore, both of them should be set to "ArmHF" configuration.

    Here are screenshots from my kits. I can't see why some projects cannot be set to the kit "ArmHF".

    Thanks in advance for your insights.. Have a good day.

    First kit:
    Screenshot_20210225_174725.png

    Second kit:
    Screenshot_20210225_174740.png


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Do you have any .pro.user file in your sources ?
    If so, you can try to move them out of the folder and reconfigure your project from scratch.



  • I had .pro.user files in my directories. Removing them and reconfiguring the project worked like a charm.

    Thank you very much @SGaist
    Problem solved.


Log in to reply