Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Selecting data from mysql using qt?



  • Why not just

    @#include <QtCore>
    #include <QtSql>@

    and not worry about every single class you use?



  • That can be a solution only when you're testing something. So, in this case, I agree with you, let's avoid such worries.

    But if your project grows up, it's better to include what's needed, otherwise your compilation time can increase a lot.

    T.



  • i add #include <QVariant>

    now it is saying
    @
    QSqlQuery::exec: database not open
    @



  • Try to use QSqlQuery::lastError() for find problem



  • what is the problem now in my code why it is not opening database?



  • Did you leave

    @
    //bool ok = db.open();
    @

    commented?



  • well i changed my code to this and added lastError as well

    @
    #include <QApplication>
    #include <QSqlDatabase>
    #include <QSqlError>
    #include <QSqlQuery>
    #include <QDebug>
    #include <QString>
    #include <QVariant>
    //#include <QtCore>
    //#include <QtSql>
    //#include "../connection.h"
    #include "db.h"

    int main(int argc, char *argv[])
    {
    QCoreApplication a(argc, argv);

    QSqlDatabase db = QSqlDatabase::addDatabase("QMYSQL");
    db.setDatabaseName("testTwo");
    db.setUserName("root");
    db.setPassword("");
    db.setHostName("localhost");
    
    //bool ok = db.open();
    
    QSqlQuery query;
    query.exec&#40;"SELECT firstname,lastname FROM testTable"&#41;;
    while(query.next()) {
        QString firstName = query.value(0).toString();
        QString secondName = query.value(1).toString();
        qDebug() << "First Name: " << firstName << "Last Name:" << secondName;
        qDebug() << db.lastError();
    }
    return a.exec&#40;&#41;;
    

    }
    @

    it still says QSqlQuery::exec: database not open



  • it is still as commented
    [quote author="Antonio Di Monaco" date="1286818410"]Did you leave

    @
    //bool ok = db.open();
    @

    commented?[/quote]



  • Try uncomment line 23



  • i uncomment line 23 and comment everything below line 23 then it just says
    @
    Starting /home/zafar/c++/dbExample-build-desktop/dbExample...
    @

    and stucks there



  • OH! You use SQL code before
    a.exec()
    !
    Are you sure?

    Create standart QT GUI application and wrote sql code in mainwindow module.



  • i am new to qt. how can i create Qt Gui App and do you mean i should write sql code in mainwindow.h file?



  • right now i have three files. db.h, db,cpp and main.cpp



  • Run QT Creator.
    Use menu File/new file or project.
    Select QT Gui application.
    ...
    and select SQL checkbox
    ...
    and write sql code in MainWindow.cpp
    ...
    and see SQL Example please



  • well i tried "File/new file or project and select qt gui app" but i ddint find any sql checkbox anywhere in creating new project



  • no coments...
    How can I send you screenshot?



  • you can add pictures here as screenshots or if you want my email address i ll give you that as well for screenshots



  • anyone who can help?





  • well i dont have that option. here is what i get
    when i click file/new file or project then this screenshot
    "Your text to link here...":http://www.freeimagehosting.net/uploads/702f633ae7.png
    then i keep clicking next getting the follwoing screenshots
    "Your text to link here...":http://www.freeimagehosting.net/uploads/ab872acfb8.png
    "Your text to link here...":http://www.freeimagehosting.net/uploads/45c51ab364.png
    "Your text to link here...":http://www.freeimagehosting.net/uploads/84605eae46.png
    "Your text to link here...":http://www.freeimagehosting.net/uploads/84605eae46.png



  • Well, it should make no problem to have SQL query before exec(), at least I don't have any problem with that.

    Let's get back to square one:
    You said if you uncomment the
    @bool ok = db.open();@
    then your program hangs. Can we see the value of 'ok'?
    @qDebug() << ok;@
    My guess is probably you have problems granting the rights in mysql when you've created the table... have you made
    @GRANT ALL ON testTwo.* to 'root'at'localhost' IDENTIFIED BY 'somepassword';@
    (Ouch please replace the 'at' with the 'at' sign, the forum motor uses it for code tags, I don't know how to write it... I hope it's not confusing.
    I'm not sure if you can do it with empty password, I guess yes, but I never do that.)



  • i now put password for root at localhost.
    when i place qDebug() << ok then it displays this
    @
    false
    QSqlQuery::exec: database not open
    @

    false might be the value of ok.



  • Are you able to connect to your DB from shell?



  • i dont know how to connect to my DB from shell. I install xampp which is easy for me to manage my databases.
    how can i connect from shell?



  • @mysql -h host -D dbname -u user@

    I guess your can omit host parameter if you are connecting to localhost. You might need to specify "-p password" switch also (depends on mysql configuration).



  • i think i did not install any mysql client. bcause it displays this output
    @
    root@zafar-laptop:/# mysql -h localhost -D testTwo -u root -p xxxxxx
    The program 'mysql' can be found in the following packages:

    • mysql-client-core-5.1
    • mysql-client-5.0
    • mysql-cluster-client-5.1
      Try: apt-get install <selected package>
      @


  • Run
    @dpkg --list | grep mysql@
    and post the output for this command.



  • here it is
    @
    root@zafar-laptop:/# dpkg --list | grep mysql
    ii libmysqlclient-dev 5.1.41-3ubuntu12.6 MySQL database development files
    ii libmysqlclient16 5.1.41-3ubuntu12.6 MySQL database client library
    ii mysql-common 5.1.41-3ubuntu12.6 MySQL database common files (e.g. /etc/mysql

    @



  • How did you create your database? I don't see any mysql server either.



  • well i download xampp and install it. i created database using phpmyadmin.



  • i install xampp in this folder /opt/lampp

    and my database is in /opt/lampp/var/mysql



  • Ok, I see. What is the location of your XAMPP installation? try to find the mysql binary there. And use the whole path (since I assume it is not in PATH) when connecting, i.e.

    @/path/to/xampp/bin/mysql -D dbname -u username@

    UPD: Didn't notice the location of xampp. then try (I guess it would be like this) @/opt/lampp/bin/mysql@



  • now here it what it says
    @
    root@zafar-laptop:/# /opt/lampp/bin/mysql -D testTwo -h localhost -u root -p 123456
    Enter password:
    ERROR 1049 (42000): Unknown database '123456'
    @
    i am providing the right pw



  • Try not passing -p switch. I guess you will be prompted to type in your password.
    or
    @/opt/lampp/bin/mysql -u root testTwo@



  • now it output is Access Denied
    @
    root@zafar-laptop:/# /opt/lampp/bin/mysql -u root testTwo
    ERROR 1045 (28000): Access denied for user 'root'at'localhost' (using password: NO)
    @



  • I'm sorry i just confused you with my last post.

    @/opt/lampp/bin/mysql -u root -p 123456 testTwo@

    I thought that mysql would prompt you but it didn't.



  • Do it this way, then it will prompt for a password:

    @/opt/lampp/bin/mysql -D testTwo -h localhost -u root -p
    @



  • i got a big ouput here but i have not seen any errors in this. when i try to post whole output this forum didnt allow me to post more than 6000 characters



  • Cut it into pieces or use something like pastebin.



  • ok here it is
    @
    root@zafar-laptop:/# /opt/lampp/bin/mysql -u root -p 123456 testTwo
    /opt/lampp/bin/mysql Ver 14.14 Distrib 5.1.41, for pc-linux-gnu (i686) using EditLine wrapper
    Copyright 2000-2008 MySQL AB, 2008 Sun Microsystems, Inc.
    This software comes with ABSOLUTELY NO WARRANTY. This is free software,
    and you are welcome to modify and redistribute it under the GPL license
    Usage: /opt/lampp/bin/mysql [OPTIONS] [database]
    -?, --help Display this help and exit.
    -I, --help Synonym for -?
    --auto-rehash Enable automatic rehashing. One doesn't need to use
    'rehash' to get table and field completion, but startup
    and reconnecting may take a longer time. Disable with
    --disable-auto-rehash.
    -A, --no-auto-rehash
    No automatic rehashing. One has to use 'rehash' to get
    table and field completion. This gives a quicker start of
    mysql and disables rehashing on reconnect. WARNING:
    options deprecated; use --disable-auto-rehash instead.
    -B, --batch Don't use history file. Disable interactive behavior.
    (Enables --silent)
    --character-sets-dir=name
    Directory where character sets are.
    --column-type-info Display column type information.
    -c, --comments Preserve comments. Send comments to the server. The
    default is --skip-comments (discard comments), enable
    with --comments
    -C, --compress Use compression in server/client protocol.
    -#, --debug[=#] This is a non-debug version. Catch this and exit
    --debug-check Check memory and open file usage at exit.
    -T, --debug-info Print some debug info at exit.
    -D, --database=name Database to use.
    --default-character-set=name
    Set the default character set.
    --delimiter=name Delimiter to be used.
    -e, --execute=name Execute command and quit. (Disables --force and history
    file)
    -E, --vertical Print the output of a query (rows) vertically.
    -f, --force Continue even if we get an sql error.
    -G, --named-commands
    Enable named commands. Named commands mean this program's
    internal commands; see mysql> help . When enabled, the
    named commands can be used from any line of the query,
    otherwise only from the first line, before an enter.
    Disable with --disable-named-commands. This option is
    disabled by default.
    -g, --no-named-commands
    Named commands are disabled. Use * form only, or use
    named commands only in the beginning of a line ending
    with a semicolon (;) Since version 10.9 the client now
    starts with this option ENABLED by default! Disable with
    '-G'. Long format commands still work from the first
    line. WARNING: option deprecated; use
    --disable-named-commands instead.
    -i, --ignore-spaces Ignore space after function names.

    @


Log in to reply