Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Problem deploying application to Android



  • Hello,
    I am having a problem when I run the my application on the android emulator. The emulator launches, (the emulator is of a google pixel) and just stays on the google sign (sometimes it loads up the home screen). Then qt is stuck on deployment for about 2 minutes and eventually stops and my application doesn't deploy on the android. The error that I'm getting says:
    Error while building/deploying project projectname (kit: Android for armeabi-v7a,arm64-v8a,x86,x86_64 (Clang Qt 5.15.0 for Android))
    When executing step "Deploy to Android device"

    Any help would be greatly appreciated.

    Thank you


  • Moderators

    @Alfie-Anil

    3 Options come to my mind

    • Launch the emulator before your compile/deploy your application, those two can be separated
    • get a better PC, seems like it has trouble launching and running the android emulator
    • get a physical device, im my experience always the best, if most expensive, option


  • @J-Hilk Thank you. I would say that my pc was good enough for this as building and deploying on desktop was seemless. Although I didn't get the emulator to work. I found that using a physical device worked.
    Thank you for your time


Log in to reply