Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Can't deploy to android



  • Hi i can't deploy to android any projects, even the example ones. My error is:

    Error while building/deploying project Test (kit: Android for armeabi-v7a,arm64-v8a,x86,x86_64 (Clang Qt 5.14.2 for Android))
    When executing step "Deploy to Android device"
    

    My specs:
    Arch Linux
    android-ndk-r21.b-1
    gradle installed externally (qt creator didn't installed it)
    android-sdk installed by android studio, api: 29 revision 4 (android 10)
    open-ssl files installed via qt creator
    android-sdk files installed/updated via qt creator (to automatically have linked ndk files)
    Qt Creator 4.12.0
    Qt 5.14.2
    GCC 5.3.1.20160406, 64 bit
    Android phone architecture: x86

    Edit:

    android: {
        QMAKE_LFLAGS += -nostdlib++
    }
    

    don't work too.

    When I only build it's good, but when I click run and choose android device it gets error about deploying.
    I found this in compiler output: Install to device: No
    Full logs: https://pastebin.com/K3xexBxB


  • Qt Champions 2019

    @Arko You should post the actual error (it should be before the lines you posted)



  • @jsulm Done, I was expanding my post and adding new information and now there's log too.


  • Qt Champions 2019

    @Arko This is actual error:

    adb: failed to install /home/adrian/Projects/build-Test-Android_for_armeabi_v7a_arm64_v8a_x86_x86_64_Clang_Qt_5_14_2_for_Android-Debug/android-build//build/outputs/apk/debug/android-build-debug.apk: Failure [INSTALL_FAILED_NO_MATCHING_ABIS: Failed to extract native libraries, res=-113]
    Installing to device failed!
    

    It means the ABI you used to build your app does not match the one of your device.



  • @jsulm Oh okay, I didn't change it so it's probably set for wrong architecture by default. Do you know where I can change that? (Or what do I need to install)


  • Qt Champions 2019

    @Arko I don't develop for Android, but as far as I know you can define the target ABI somewhere in QtCreator.



  • Ok, I tried to search for it but I couldn't find it. Does anyone know how to change target android architecture for building apks?



  • @Arko Click on Project in the left pane then choose Build under your Build & Run configuration. In the Build Steps, look for "qmake:". Expand it by clicking on Details and choose the target ABI.


Log in to reply