Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Android application debug not working in my xiaomi device



  • I can deploy the application successful but when ever I try to debug I get the following error:
    The command "/home/bongani/Android/Sdk/platform-tools/adb" terminated with exit code 1.
    adb: error: listener 'tcp:5038' not found
    I/System.out(30436): Sending WAIT chunk



  • I have absolutely the same thing. Device is Samsung G800F. QtCreator 4.11.1, Qt 5.14.1, Windows 7

    I tried to connect to adb via USB and via Wifi, the result is the same. The application is deployed, launched on the device, and the debugger breaks:

    adb.exe: error: listener 'tcp:5038' not found

    Does anyone have Android debugging from QtCreator?


  • Moderators

    this, for both cases is an issue of the OEM.

    QtCreator supports debugging where AndroidStudio supports it.

    Samsung and Xiamoi do their own thing.

    You can use a virtual Android device, those work all fine. Or - and I can't believe I'm saying this - you can get a pixel phone, those should - "should", its google - always be supported.



  • In Android Studio on the same device, the same computer and with the same SDK, debugging works fine! The problem is in the QtCreator and Qt projects



  • I found this and this. It is bug QtCreator.
    How can I downgrade QtCreator? In QtCreator 4.8 Android debugging worked, I remember.


Log in to reply