Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Using qt 5.12.5 version wanna change 'QMAKE_XSPEC android-clang' to android-gcc.



  • My qmake is using clang for android and project can be run on only gcc and i am not able to add new version for android as my qt is showing only the auto detected versions, tell me how to shift to gcc.

    Name:
    Qt 5.12.5 for Android ARMv7
    ABI:
    arm-linux-android-elf-32bit
    Source:
    C:\Qt\5.12.5\android_armv7
    mkspec:
    android-clang
    qmake:
    C:\Qt\5.12.5\android_armv7\bin\qmake.exe
    Version:
    5.12.5
    QMAKE_SPEC
    win32-g++
    QMAKE_VERSION
    3.1
    QMAKE_XSPEC
    android-clang

    QT_HOST_BINS
    C:\Qt\5.12.5\android_armv7\bin
    QT_HOST_DATA
    C:\Qt\5.12.5\android_armv7
    QT_HOST_LIBS
    C:\Qt\5.12.5\android_armv7\lib
    QT_HOST_PREFIX
    C:\Qt\5.12.5\android_armv7
    QT_INSTALL_ARCHDATA
    C:\Qt\5.12.5\android_armv7
    QT_INSTALL_BINS
    C:\Qt\5.12.5\android_armv7\bin
    QT_INSTALL_CONFIGURATION

    QT_INSTALL_DATA
    C:\Qt\5.12.5\android_armv7
    QT_INSTALL_DEMOS
    C:\Qt\Examples\Qt-5.12.5
    QT_INSTALL_DOCS
    C:\Qt\Docs\Qt-5.12.5
    QT_INSTALL_EXAMPLES
    C:\Qt\Examples\Qt-5.12.5
    QT_INSTALL_HEADERS
    C:\Qt\5.12.5\android_armv7\include
    QT_INSTALL_IMPORTS
    C:\Qt\5.12.5\android_armv7\imports
    QT_INSTALL_LIBEXECS
    C:\Qt\5.12.5\android_armv7\bin
    QT_INSTALL_LIBS
    C:\Qt\5.12.5\android_armv7\lib
    QT_INSTALL_PLUGINS
    C:\Qt\5.12.5\android_armv7\plugins
    QT_INSTALL_PREFIX
    C:\Qt\5.12.5\android_armv7
    QT_INSTALL_QML
    C:\Qt\5.12.5\android_armv7\qml
    QT_INSTALL_TESTS
    C:\Qt\5.12.5\android_armv7\tests
    QT_INSTALL_TRANSLATIONS
    C:\Qt\5.12.5\android_armv7\translations
    QT_SYSROOT

    QT_VERSION
    5.12.5

    • list item

  • Lifetime Qt Champion

    Hi and welcome to devnet,

    AFAIK, Google switch to clang a few years ago so unless you are using an old NDK, you'll have to do with clang.

    See the Android Getting Started guide for information about Qt versions and NDK requirements.


Log in to reply