Important: Please read the Qt Code of Conduct -

Setting up QT Creator devices from windows, cross-compile on VMWare for buildroot RPi

  • Good Afternoon,
    I am just beginning here, I apologize for leaving out any details.
    QT Creator is installed on a Windows 10 machine. VMWare is running Ubuntu, and the issue is in regards to setting up devices on QT Creator. I would like to use a cross-compiling toolchain found in the Ubuntu box. the SSH part of testing a Generic Linux Device works. it give me the linux version within ubuntu. the sftp and RSYNC fails. This is the response from the test

    Connecting to host...
    Checking kernel version...
    Linux 5.0.0-37-generic x86_64

    Checking if specified ports are available...
    All specified ports are available.

    Checking whether an SFTP connection can be set up...
    Error setting up SFTP connection: File transfer failed: mike@ Permission denied (publickey,password).
    Connection closed

    Checking whether rsync works...
    Failed to start rsync: Process failed to start: The system cannot find the file specified.

    Deployment to this device will not work out of the box.

    Device test failed.

    Any suggestions would be greatly appreciated.

  • @AutoSpiderZ

    Hi and welcome to devnet forum

    Typically for cross-compiling you would need to install all required libs on windows in your case. Not sure if they are completly identical if you take those from windows.

    The easiest in your case wold be to install Qt also on linux in VM. With Qt creator you can use the "same" build environment on both OS. So the look and feel is the same, which makes it comfortable.

    Otherwise you can install the complete cross-compile toolchain for RPi on windows and leave out VM with linux.

  • Good Afternoon,
    I do agree, it would be nicer to use QT directly in linux, but being unable to do that to get cross compilers to build correctly directly on Windows through a buildroot in msys or cygwin or even PS. Especially trying to build mysql connectors for the buildroot'd RPi. Still, working through a Virtual Machine seems to be a decent alternative and it seems to me that at least setting up the devices should work ok.
    Anyways, here is a screenshot at the point I have been getting stuck at.
    Screenshot (33).png Screenshot (31).png

  • @AutoSpiderZ

    It looks like it should work. However, completely outside of my field of experience.

    Is the linux under VM already a build which would run also on RPi?

  • same issue

  • Same problem.
    Or if i uncheck "Check host key", i am get error
    Error setting up SFTP connection: File transfer failed: root@XXXXXXX: Permission denied (password).

  • Hello everybody,
    I think that I have the same problem and, search inside various pages, it' s many confusional.
    If the problem is resolved, can you give me the solution or probable solution?
    I used the Qt creator 4.12.4.
    In attached the problem.
    Best regards.2432df2c-8173-4120-a396-7242badd7772-image.png

  • Lifetime Qt Champion

    @Fiore Did you make sure SFTP and/or rsync work (can you access your device via SFTP or rsync)?

  • Hi Everybody.

    In my case I had to install openSSH server from control panel. After that when I tried to test my connection I got the same result. After a while I reailzed when I tested the connection with public key I just gave the private key and did not deploy the public key. After I deployed the sftp connection worked well. However I am still in trouble with rsync on windows host. I hope this "half" idea could help to you.


Log in to reply