Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QPSQL driver not loaded QT 5.13.2



  • hello
    I tried to connect to PostgresSQL using QT 5.13.2 Mingw32 on windows, I use the simple code to make the connection but i got the common Error

    QSqlDatabase: PSQL driver not loaded
    QSqlDatabase: available drivers: QSQLITE QODBC QODBC3 QPSQL QPSQL7
    "Driver not loaded Driver not loaded"
    

    I copy all the dlls needed to my EXE folder using WindDeploy and then download Windows Binaries of postgresql from it's website Here, I download 9.3.25 Version and copy the dlls

    libeay32.dll
    libintl.dll
    libpq.dll
    ssleay32.dll
    

    to my folder that has the EXE, but i still got the same problem i don't know why, and almost all the solution that solved this problem in the past was saying this solution to copy the dlls from the PostgresSQL folder to your EXE folder, i dont know if i need maybe a higher version of PostgresSQL binaries for windows for a new dlls, I go from PostgresSQL version 9.2 to 9.10 and no dll helped me.


  • Lifetime Qt Champion

    Hi,

    Start your application with the QT_DEBUG_PLUGINS environment variable set to 1. It will give you more information about what is happening.


  • Lifetime Qt Champion

    Apart from this take a look what Dependency Walker (or Dependencies-Gui) is telling you about missing libraries.


Log in to reply