Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Why can't the libraries from qt-everywhere-src-5.13.0 be found on my BeagleBoard?



  • Hello,

    I built qt-everywhere-src-5.13.0 with arm-linux-gnueabi and uploaded the libraries to my board. The executable can search the right path (/opt/qt-arm/lib) where the libraries are:
    0_1564559945230_787897f6-efd0-404f-b28e-6bf0689fb4b6-image.png

    0_1564560516011_7b5f9308-95d6-48d6-9644-02446fe6cef7-image.png

    But it just can't find the sonames and an error message shows, even they are right there obviously:
    0_1564560058247_2b6f353c-80b6-400a-b6bb-809f487bbe53-image.png

    0_1564560113040_3c6a1a9b-05c2-443f-afab-2ef7be2a0b65-image.png

    When I run ldd, it shows "not a dynamic executive".
    When I run file, it shows it's dynamically linked.
    0_1564559172840_bb44147a-4c11-4e8a-a8f9-ac049f246685-image.png

    Any suggestions? I just don't know what happened.


  • Qt Champions 2019

    @billliu Are you sure you built the libs for ARM?
    What does

    file ONE_OF_QT_LIBS
    

    say?



  • @jsulm

    Thanks for your reply.

    debian@beaglebone:/opt/qt-arm/lib$ file libQt5Widgets.so.5.13.0
    libQt5Widgets.so.5.13.0: ELF 32-bit LSB shared object, ARM, EABI5 version 1 (GNU/Linux), dynamically linked, BuildID[sha1]=b94b037260dda91a1e719e919c4b2b3da01d3959, stripped


  • Qt Champions 2019

    @billliu Did you build the executable on your host machine or target device?
    Did you check the access rights for the libs?



  • @jsulm I built the executable in QtCreater on my host machine. I set a kit for my target device. If no Qt library is used, it can work on my target device.

    I am trying to check information such as the followings .

    -rw-r--r-- 1 root root 767 Jul 30 2019 libQt5Widgets.la
    -rw-r--r-- 1 root root 1149 Jul 30 2019 libQt5Widgets.prl
    lrwxrwxrwx 1 root root 23 Jul 30 2019 libQt5Widgets.so -> libQt5Widgets.so.5.13.0
    lrwxrwxrwx 1 root root 23 Jul 30 2019 libQt5Widgets.so.5 -> libQt5Widgets.so.5.13.0
    lrwxrwxrwx 1 root root 23 Jul 30 2019 libQt5Widgets.so.5.13 -> libQt5Widgets.so.5.13.0
    -rwxr-xr-x 1 root root 5550140 Jul 30 2019 libQt5Widgets.so.5.13.0

    I have not found something strange yet, but I don't know much about this.


Log in to reply