Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

qtmqtt Installation fails



  • Hello everyone! My setup is KDE Neon 15.5 (Based on Ubuntu 18.04)
    I installed Qt creator and hopefully everything I need by doing:

    $ sudo apt-get install qt5-default
    $ sudo apt-get install qtcreator
    $ sudo apt install qtdeclarative5-private-dev
    

    Some other information that might be useful:

    $ qmake -query QT_INSTALL_LIBS
    /usr/lib/x86_64-linux-gnu
    $ qmake --version
    QMake version 3.1
    Using Qt version 5.12.0 in /usr/lib/x86_64-linux-gnu
    
    

    Then I tried installing the QT MQTT module in my home directory by doing:

    $ git clone -b 5.12 https://code.qt.io/qt/qtmqtt.git
    $ cd qmqtt
    $ mkdir build
    $ cd build
    $ qmake -r ..
    

    which yields:

    Info: creating stash file /home/lopeztel/Qt/qtmqtt/build/.qmake.stash
    Info: creating cache file /home/lopeztel/Qt/qtmqtt/build/.qmake.cache
    Reading /home/lopeztel/Qt/qtmqtt/src/src.pro [/home/lopeztel/Qt/qtmqtt/build/src]
     Reading /home/lopeztel/Qt/qtmqtt/src/mqtt/mqtt.pro [/home/lopeztel/Qt/qtmqtt/build/src/mqtt]
    Project MESSAGE: perl -w /usr/lib/qt5/bin/syncqt.pl -module QtMqtt -version 5.12.3 -outdir /home/lopeztel/Qt/qtmqtt/build -builddir /home/lopeztel/Qt/qtmqtt/build /home/lopeztel/Qt/qtmqtt
    <srcbase> = /home/lopeztel/Qt/qtmqtt 
    <bldbase> = /home/lopeztel/Qt/qtmqtt/build 
    <outbase> = /home/lopeztel/Qt/qtmqtt/build 
    QtMqtt: created fwd-include header(s) for <srcbase>/src/mqtt/ { qmqttauthenticationproperties.h (2), qmqttclient.h (2), qmqttclient_p.h (1), qmqttconnection_p.h (1), qmqttconnectionproperties.h (4), qmqttconnectionproperties_p.h (1), qmqttcontrolpacket_p.h (1), qmqttglobal.h (1), qmqttmessage.h (2), qmqttmessage_p.h (1), qmqttpublishproperties.h (3), qmqttpublishproperties_p.h (1), qmqttsubscription.h (2), qmqttsubscription_p.h (1), qmqttsubscriptionproperties.h (3), qmqtttopicfilter.h (2), qmqtttopicname.h (2), qmqtttype.h (3) }
    QtMqtt: created version header
    QtMqtt: created master header
    QtMqtt: created headers.pri file
    Project ERROR: Unknown module(s) in QT: core-private
    

    I've spent some time trying to find the problem but I could't, I even tried to install Qt using the online installer: "qt-unified-linux-x64-3.1.1-online.run" but it didn't work, there must be something I'm not seeing ... no idea how to get this Project ERROR: Unknown module(s) in QT: core-private to go away.

    From what I know this is a standalone module and doesn't require any kind of license but I could be wrong... Any help would be greatly appreciated


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Since you are using your distribution provided Qt, you need to install the qtbase5-private-dev package.



  • @SGaist Thanks a lot! I know there was something simple I wasn't seeing