Flickering Animations on QNX



  • Hi, we are currently experiencing issues running Qt UI applications on a ZCU102 evaluation board running QNX 7. The issue manifests as a black flickering that occurs whenever there is any animation on the screen. The same applications run fine without flickering on Desktop Linux. We've tested on different monitors/cables.

    When running built in graphics demos (on the ZCU102 board), this flickering does not occur, only when running Qt UI applications. We are attempting to run Qt Quick 2 applications, but the issue also manifests when running Qt demos such as the OpenGLWindow example application.

    The animation test application we are running is using Qt Quick 2 and is a simple Rectangle animating back and forth.

    The following video is running the animation test on Desktop Linux
    https://streamable.com/53554

    And this video is the display out from the QNX target:
    https://streamable.com/84sva

    The graphics.conf we are using is here:

    begin khronos
    
      begin egl display 1
        egl-dlls = libmali.so
        glesv1-dlls = libmali.so
        glesv2-dlls = libmali.so
        gpu-dlls = libmali-kbase.so
      end egl display
    
      begin wfd device 1
        wfd-dlls = libwfdcfg-zcu102.so libWFDzynq.so
      end wfd device
    
    end khronos
    
    begin winmgr
    
      begin globals
        input-logsize = 8192
        input = keyboard mouse
        requests-logsize = 65536
        alloc-config = zynq-alloc
      end globals
    
      begin display internal
        video-mode = 1280 x 720 @ 60
      end display
    
      begin class framebuffer
        display = internal
        pipeline = 2
        format = rgba8888
        usage = sw
      end class
    
    end winmgr
    

    It seems that the streams coming from the actual process are good and do not have the flicker (under /dev/screen/[process-id]/str-0, but the frame buffer under /dev/screen/0/str-1 does contain the flickering.

    I also have all of the debugging output from /dev/screen/ on the target device, but I am unable to upload all of the files to the forum due to privileges.


  • Lifetime Qt Champion

    Hi,

    There might not be anyone here being able to answer QNX related question. You should check the #qt-qnx IRC channel on freenode to see if you can have somebody taking a look at you thread here.



  • @SGaist Yeah, I figured that would probably be the case. Thanks!


Log in to reply