Ok, i got it:
// Disambiguate overloaded member function below with static cast
connect(socket, static_cast<void (QTcpSocket::*) (QAbstractSocket::SocketError)>(&QTcpSocket::error), this, &Network::socketErrorSlot);
I think that deserves to be in bugtracker, isn't it? Not good idea to implement new notation and use the same names for method and signal.