I agree with joe.skb7
If you are following Java coding standards (getters begin with get - getSomething()) then members can really be named without some kind of prefix, but here it is awkward. (having "this->" before everything produces a lot more visual clutter than m_ or just _)
If you are writing a library and are concerned about the binary compatibility, then you could go for the d-ptr pattern (like Qt does). This way all private members would be in the Private class instead of the main one and you'd access them as d->name or similar.