Important: Please read the Qt Code of Conduct -

Downloading QT Developer open source for about the 4th time

  • Let me begin by saying I miss my early days of programming. All that was needed was a compiler or interpreter and some sort of text editor. Since the GUI has become the standard, it's become more difficult to download, install and use an IDE to make even the most basic (no pun intended) of programs. Having bitched about that, let me explain my current situation.
    I've downloaded the open source version of QT and installed it without really changing anything. I had to select a folder (it won't allow installation on the /Applications folder on Mac OS for some reason) and I had to "select all" when telling the installation program which options I want. Other than that, I let it find compilers and other components on my MacBook by itself.
    Well, one of the things I've had trouble with is kits. The first time I installed, I did NOT "select all" when installing and thus no kits could be found by QT or installed by me. After a few tries, I got the IDE installed and working and I was following two different tutorials on how to use it.
    All of a sudden, without my doing anything, it decided that there were no valid kits installed and I could no longer work on the projects that I had been coding, building and running for the last several days. I spent plenty of time staring at the kits configuration page which just like before, resulted in no progress whatsoever. I still have no idea how to install a kit and when QT decided it didn't have any kits installed (despite the fact that the kit configuration page showed at least 2) I could no longer work on my projects.
    As if this wasn't bad enough, I tried to fix this problem the same way I've fixed it a few times before. I removed the entire installation of QT and went to the website to download and install it again. Well, I logged on, downloaded the installer app, then logged into the installer app in order to begin the download. The installer app gave me the following message.

    Not authorized.

    No reason. No solution. No link to contact anybody. Just Not authorized. Needless to say I'm very, very frustrated and I don't want to have to find another IDE (I've already given up on XCode about a million times) to develop programs. Please help!

  • Lifetime Qt Champion


    What version of macOS are you using ?

    You don't need to login to get the Open Source version of Qt.

    The /Application folder is protected because it's shared among all computer users. You should rather keep the default installation path in your user's folder.

    There's no need to select everything especially if you intend to only develop on macOS. Just select the macOS build.

    What exactly did the Kit page show once you had that message in Qt Creator ?

    By the way, it's Qt, QT stands for Apple's QuickTime which is likely not what you want to develop with.

Log in to reply