Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Can not build application msvc2017, Qt 5.10.1, Qt creator 4.8.1



  • When I try to build an application in qt Creator I get the following

    17:50:31: Running steps for project qtCameraScannerToWindows ...
    17:50:31: Starting: "C:\Qt\5.10.1\msvc2017_64\bin\qmake.exe" "C:\Users\xxxxx\source\gitRepo\qtCameraScannerToWindows - Copy\qtCameraScannerToWindows .pro" "CONFIG+=debug" "CONFIG+=qml_debug"
    17:50:33: The process "C:\Qt\5.10.1\msvc2017_64\bin\qmake.exe" exited normally.
    17:50:33: Starting: "C:\Qt\5.10.1\msvc2017_64\bin\qmake.exe" -f C:/Users/xxxxx/source/gitRepo/build-qtCameraScannerToWindows - Copy_Qt_5_10_1_MSVC2017_64bit-Debug/Makefile qmake_all
    Usage: C:\Qt\5.10.1\msvc2017_64\bin\qmake.exe [mode] [options] [files]
    
    QMake has two modes, one mode for generating project files based on
    some heuristics, and the other for generating makefiles. Normally you
    shouldn't need to specify a mode, as makefile generation is the default
    mode for qmake, but you may use this to test qmake on an existing project
    <some help text here and then>
    ***Unknown option -f
    17:50:33: The process "C:\Qt\5.10.1\msvc2017_64\bin\qmake.exe" exited with code 1.
    Error while building/deploying project qtCameraScannerToWindows (kit: Desktop Qt 5.10.1 MSVC2017 64bit)
    When executing step "qmake"
    

    This is my kit
    1_1549987118278_kit.JPG 0_1549987118276_compilers.JPG

    Any guesses of what might be going wrong?
    My project compiles cleanly in Visual Studio with QT for VS Tools


  • Lifetime Qt Champion

    @Umbaman your MSVC installations is faulty.

    You cannot set up MSVC compiler manually, it must be auto detected. did you install MSVC at the default location?



  • @aha_1980 Yes I did!
    I'm trying for 2 days to get the compiler autodetected by removing and reinstalling qt several times and installing whatever I thought was relevant through visual studio installer.
    When installing visual studio professional I just let the visual studio installer to do its job, I didn't change anything.
    As I final solution I set it manually


  • Lifetime Qt Champion

    @Umbaman

    • Which Windows version is that exactly?
    • Do you have any anti-virus running?

    Qt Creator needs the vcvarsXXX.bat file the detect the compiler. Further, this file does set some environment variables, otherwise the compiler will not work. We have seen some problems with executing this batch file in the past, but things have improved in the latest Creator versions (4.7, 4.8).

    That makes me puzzle what's wrong on your system...


  • Lifetime Qt Champion

    @Umbaman said in Can not build application msvc2017, Qt 5.10.1, Qt creator 4.8.1:

    When installing visual studio professional I just let the visual studio installer to do its job, I didn't change anything.

    I think this is the problem. By default C++ part is not installed, you need to select it explicitly.



  • Thank you both for the replies

    @aha_1980

    0_1550045223510_Windows Version.JPG

    1. Windows Defender is used as antivirus

    2. This is where all vcvars files are

      C:\Program Files (x86)\Microsoft Visual Studio\2017\Professional\VC\Auxiliary\Build

    @jsulm

    This is what I have installed
    0_1550045473137_visual Studio Desktop development with C++.JPG
    0_1550045460703_visual Studio individual components.JPG



  • Do I need to run vcvars manually?


  • Lifetime Qt Champion

    @Umbaman

    No, Creator runs it for you. But you can check if you can open a Visual Studio command prompt from the Start Menu. That should exec the same batch file and set up the environment.

    Does that work without problems?



  • @aha_1980
    Yes It does.!



  • After line 3 the qmake exited normally, it start the qmake again with "-f" param, I think it should be jom.exe not qmake.exe, qmake has no option "-f", did you change it?



  • @Jerry.Wilson
    No I didn't! I don't even know how. I wanted to remove the -f option



  • @Umbaman
    Mmm...as I saw in your picture, you choose qmake.exe as your make tool in the Make Path, I think that is the reason. Qmake is not a make tool, use jom.exe and try again.



  • @Jerry.Wilson hmmm. Something seems to be happening.

    This is what I am getting now

    C:\Qt\5.10.1\msvc2017_64\include\QtCore/qglobal.h(45): fatal error C1083: Cannot open include file: 'type_traits': No such file or directory
    

    Edit:
    this guy here (https://nnarain.github.io/2017/11/10/Config-issues-with-Qt-and-Visual-Studio.html) nailed it!
    The corresponding registry key was pointing to the community edition I had, before installing visual studio professional.

    I can see a few compilers now autodetected, but not a single kit autoconfigured...
    Manually setting a compiler seems to be working but I cannot compile my project correctly.

    Example Output

    :-1: error: LNK1181: cannot open input file 'debug\main.obj'


  • Lifetime Qt Champion

    @Umbaman,

    good, it seems we get forward :)

    • Can you show your compilers and kits screens again now?
    • Can you check if a newly created project compiles?
    • If not, please post the complete compile output.

    Regards



    1. Compilers

    0_1550151994648_newCompilers.JPG

    Kits
    0_1550151918677_new Kits.JPG

    1. A new project compiles, runs and can be debugged successfully using the Desktop Kit. I was getting the error mentioned due to white spaces in my path.

    As for the UWP kit I get the following output

    :-1: warning: winrt_manifest_install.path is not defined: install target not created
    

    therefore nothing happens when I run the project.


  • Lifetime Qt Champion

    @Umbaman

    Do you need UWP/WinRT? I'm out here, I have never used it...



  • Yes I do.
    I need to develop apps for Windows 10 IoT.


Log in to reply