QtCreator, Debugger does not attached to the application

  • Moderators

    Hi everyone, I've run into an issue with QtCreator and I'm looking for directions to look into, to fix it.

    The latest update broke the debugger support for my version QtCreator. It doesn't matter if I try to debug a project of mine or a simple main (Hello World) application.

    QtC: 4.8.1
    Qt-Version: 5.12.1
    Compiler: MSVC2015 64bit
    Debugger: CDB (From Windows/10/Debuggers/x64/cdb.exe)

    Currently as a workaround, I have VisualStudio open and attach the debugger there to the running process. That works, but is really cumbersome and suboptimal.

    I don't know what happened, but the only thing I can think of is a complete reinstall of everything. QtC VS - (maybe update to 2017) but that's a step I would like to do as a last resort.


    Edit: I should mention, that when I use mingw and gdb, it does indeed still work in QtCreator, but I'm not allowed to use mingw for most of my projects.

  • Lifetime Qt Champion

    Have you tried running a repair on the VS installation?
    (via the installer)

    Its worth a shot. (IMHO)

  • Qt Champions 2018

    @J.Hilk First have a look at the Debugger Log (Windows > Views > Debugger Log) first. Most often this gives a hint for the root problem.

  • Moderators

    I tried, and now it's working. I didn't change anything....

    Threaded classes, custom (Qt-based dlls) I can step into everything.

    I blame gremlins.

  • Lifetime Qt Champion

    alt text

    blame me !! ;)

  • Lifetime Qt Champion

    @mrjj that's not a gremlin, he's a mogwai ;-)

  • Lifetime Qt Champion

    Indeed he is
       but if you feed him bugs
    after midnight then he goes like

    alt text

    but then you find the actual reason
       for all your problems and then you
    feel like

    alt text


Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.