macdeployqt 5.12.1 command not found

  • Hi,

    I have been using QT for a little over a month after taking over a project after another developer left. I spent most of the month learning QT and the apps and about a week ago I finished updating from 4x to 5x and built and deployed the apps on Windows. I finished updating the Mac versions and building and running them from QT Creator yesterday morning, but when I attemped to deploy them, I ran into the following error message that I have spent the last day and a half trying to resolve myself:

    -bash: macdeployqt: command not found

    I reinstalled QT, I attempted to fix my $PATH and a lot of other things, but I am finally stopping for the night. Any ideas are welcome.

    Thanks You!

    Anton Bursch

  • Moderators

    @AntonBursch said in macdeployqt 5.12.1 command not found:


    you'll have ti fix your path to the macdeployqt it's to be found, under

    replace x.x with the qt version of course

  • @J.Hilk

    I was trying to add the path, but my changes weren't saving. I tried again this morning and instead of closing the terminal to see if the changes were saved, I simply attempted to use macdeployqt and it worked! Now I have other issues to deal with and I need to figure out why my changes to path aren't saving, but at least I can use the macdeloyqt tool now!

    Thank You!

    Anton Bursch

Log in to reply