Nominate our 2022 Qt Champions!

QtCreator complains that "Android SDK is missing necessary packages," does nothing.

  • Everything else under Devices/Android is checked off as being OK. The one red X is "Platform SDK installed." But the platform SDK is installed. I installed Android Studio and the NDK.

    Every time I visit this page, I get a dialog saying ,"Android SDK installation is missing necessary packages. Do you want to install the missing packages?"

    And then I choose Yes. And nothing happens.

    Anybody know how to resolve this?


  • @Stokestack

    What OS are you on?

    Best is to post a screen shot.
    Also look out for special signs when you receive such messages. Qt creator typically tells where the issue is. Hovering with mouse above the signs give also some hints on how to resolve.

  • Hi. Thanks for your answer. I'm on Mac OS (latest, Mojave).

    I don't see anything to hover over that provides any more info. Here's a screen shot:

    0_1548971647657_QtAndroidSetup.png image url)

  • @Stokestack

    I do not know about Mac, but on windows it looks like this
    0_1549007225914_0d5a4f7a-ef90-4b9e-aca8-d8a182e6ea74-image.png 0_1549006894585_b0866f0c-ff42-4a98-b996-532c34d22018-image.png

    There is the cmake folder in addition. I gugess that is not required. On windows I have a couple of different folders under build-tools. These folders seem to indicate the SDK version numbers.
    IIRC I had to install an SDK when starting the Android suite the first time. Some of those versions I had added lateron.

  • Moderators

    from the screenshot I would say the sdk folder is indeed missing, it should look like this

    My SDK installation comes from the link QtCreator provides, when you click on the button right of the choose button, the one with the green arrow.

  • Thanks for the replies, guys.

    Android Studio shows that the SDK is installed:

    0_1549068804953_Screen Shot 2019-02-01 at 4.50.18 PM.png

  • @Stokestack

    In case you still have issues, it could be better to install an older SDK version. You want to check if there is already a bug report on JIRA.. Possibly your Qt creator version is not yet compatible with the latest Android SDK. So far in the past it was always better to stay with older SDK versions, see also

  • @koahnig Thanks for the info. I will try that.

  • Well, I installed the previous Android SDK version as well, and Qt still claims that it's not installed. This despite still showing that all the other Android stuff is installed.

  • @koahnig Well, now I've installed the Android SDKs back to API version 25, and still no dice. I just updated to Qt 5.12.1, too.

    This is pretty much a show-stopper...

    I'd file a bug report, but my log-in ID is somehow messed up and there's no way to contact an admin for the bug tracker (kind of a big problem in its own right).

  • @Stokestack

    SDK version 25 seems to be too early for Qt5.12.1, but that is more a gut feeling.

    I am currently using 0_1551777190331_e9c264b9-7c42-49b0-8ee2-c5155f4430a2-image.png with Qt5.11.3 on windows 10 64 bit.

  • @Stokestack

    and that is the version combination I got to compile and run with Qt 5.12.1
    Resepctively to be very precise it is the tool chain indicated as Android for armeabi-v7a (Clang Qt 5.12.1 for Android ARMv73) in creator.

  • Thanks for the reply.

    I have every version of Android SDK from 25 UP.

  • Lifetime Qt Champion


    I've seen several developers posts having trouble with the SDK coming from Android Studio.

    AFAIR, the solution was to use the "Command line tools only" download option.

  • @SGaist Thanks.

    Actually... I think the SDK (or JRE) that's buried in the Android Studio installation may be the only one that still works. Maybe they're shipping their own version of the now-deleted components.

    I don't even remember how I discovered this workaround... but if you go into Devices/Android in Qt Creator preferences and direct the JDK location to the one that's installed by Android Studio... it seems to work.

    On the Mac, that location is:

    So anyone who's experiencing this, give that a try and let us know how it goes.

  • Lifetime Qt Champion

    Thanks for the feedback !

  • @SGaist No problem. I should have posted this before but got sidetracked.

    Here's a screen shot of how things look on my system now. The other paths (starting with /Developer) are where I told Android Studio to install all of its supporting files (or its installer defaulted to; I don't remember).


  • Lifetime Qt Champion

    Since you have it working now, please mark the thread as solved using the "Topic Tools" button so that other forum users may know a solution has been found :)

Log in to reply