Debugging of Android applications with creator

  • I tried to debug an application compiled debug settings through creator on windows 10 64 bit.

    Currently I am using Qt 5.11.3 as listed here

    with armeabi-v7a the virtual device is not even starting. Therefore I have addd already the android for x86 kit. This does start the virtual device, but debugging is not possible.

    I have checked and the debug server as listed for android for x86 is in place and can be started on command line.

    This is the output to the application pane in creator

    21:07:11: Debugging starts
    I art     : Not late-enabling -Xcheck:jni (already on)
    W art     : Unexpected CPU variant for X86 using defaults: x86
    W ActivityThread: Application org.qtproject.example.satelliteinfo is waiting for the debugger on port 8100...
    I System.out: Sending WAIT chunk
    I art     : Ignoring second debugger -- accepting and dropping
    Could not load shared library symbols for 137 libraries, e.g. /system/lib/
    Use the "info sharedlibrary" command to see the complete listing.
    Do you need "set solib-search-path" or "set sysroot"?

    and this is the output shown on virtual device:

  • The problem could be solved by updating the Android suite to newest version.

  • on Qt Creator
    in Tools > Options > Debugger > GDB > Additional Attatch Commands
    ex. Insert "set solib-search-path /opt/Qt/5.12.1/android_x86/lib"

Log in to reply