Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qt - QML Image: TLS initialization failed



  • Hi , i was solving the problem of ssl , i downloaded openssl and last version , and copied the DLL files to three /bin of minGw , but this not helped me , i'm trying to parse xml file include only images to XmlListModel , so the problem is only this three images showing
    alt text
    , i'm already know that the server is the problem , but why Qt not reading all images ?
    i searched about 4 month to fix
    qt.network.ssl: QSslSocket::connectToHostEncrypted: TLS initialization failed

    i tried the environment but nothing happened , please help !! sorry fory the good english :D :)
    alt text
    :)
    and the openssl version :
    OpenSSL 1.0.2l



  • help guys :) ?


  • Lifetime Qt Champion

    Hi,

    Please show some patience and allow 24 hours to pass before bumping your thread. People answering here do it on their own time and might not live in the same timezone as you.

    As for your problem, where did you put your OpenSSL libraries exactly ?
    What version of Qt are you using ? (you are showing the Qt Creator about box which is not the same thing=



  • @SGaist first thank you for your reply ,
    i put the libraries ( from C:\OpenSSL-Win32\bin) to the following path:
    C:\Qt\Qt5.12.0\5.12.0\mingw73_64\bin
    C:\Qt\Qt5.12.0\Tools\mingw730_64\bin
    .
    and iam using the last version of Qt which is 5.12 , :)


  • Lifetime Qt Champion

    IIRC, Qt 5.12 is built using the OpenSSL 1.1 backend, you should check with that one.



  • @SGaist i tried my best and i've done this but it show the error , any idea ?
    alt text
    ******without importing library all pictures works but only my Uploaded Picture not working and some internet image not working and telling me :

    qt.network.ssl: QSslSocket::connectToHostEncrypted: TLS initialization failed**
    qrc:/main.qml:24:13: QML Image: TLS initialization failed
    alt text
    the problem is just openssl :) what i've to do next ?
    ****


  • Lifetime Qt Champion

    It looks like you are trying to use a 32bit build of OpenSSL with a 64 bit version of Qt.



  • @SGaist Now the library import have no problem , but still show the error , run qmake , rebuild , nothing happen :(
    alt text



  • @SGaist can you give link and name of the 64bit version , i've downloaded everything



  • @SGaist i've downloaded Win64 OpenSSL v1.1.1a - 43MB Installer , and there's no ssleay and libeay library :)


  • Lifetime Qt Champion

    Because the name of the libraries have changed. OpenSSL 1.1 is not backward compatible with 1.0.

    But in any case, you don't have to link the libraries, Qt dlopens them.



  • @SGaist so i have deleted the linking , now only thing i've added is the openssl.cfg to Environment , so what to do ? copy all new library and put them to
    C:\Qt\Qt5.12.0\5.12.0\mingw73_64\bin
    C:\Qt\Qt5.12.0\Tools\mingw730_64\bin

    this will fix the problem ?

    Edited:
    new names are libcrypto-1_1.dll and libssl-1_1.dll , copied to 2 path , Rebuild , Again same problem :) any idea ?


  • Lifetime Qt Champion

    Go to the Run part of the Project panel and modify the PATH environment variable by putting the folder where you can find the OpenSSL dlls.



  • @SGaist during 4 months i downloaded everything on http://slproweb.com/products/Win32OpenSSL.html

    only one thing i haven't download it , it was this Win64OpenSSL 1.0.2q - Light
    by copying the 3 library to bin paths %
    Finalyyyyyyy Rebuild and it work !!,
    Thank you @SGaist for eeverything :) <3


Log in to reply