Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

New Qt messages.



  • Hello!!

    I downloaded the lastest version of Qt. When I am coding, it appears warnings in red and yellow at right. I think this is slowing down the program and now, Qt spend a lot of time to recognise the autocomplete tool.

    0_1544023759353_4c71a02b-54fe-4be1-b046-8196338b7ee9-image.png

    Does anyone know how to disable that or improve the performance?

    Thank you very much!!


  • Lifetime Qt Champion

    @ivanicy

    1. Use nullptr instead of 0 for pointers
    2. For the error: please show the code, not just error message (it looks like you're passing a non-QWidget as parameter where QWidget is expected)

    Actually it is better to copy paste warnings/errors instead of posting screen-shots...



  • @jsulm Sorry, I'm not trying to fix the warnings, I am trying to hide this kind of comments.



  • If you want to make it lighter go to tools->options->C++->code model and under "Clang code model" select a lighter option like "check for questionable constructs"
    To disable it completely go to help->about plugin, untick clang code model and restart Qt creator.


  • Moderators

    @ivanicy
    The auto completer becomes slow-with the new code model- only if you have a couple thousand lines of code in a single class.

    If thats the case, you should consider refactoring and splitting your code up.


Log in to reply