Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QtCreator on TinkerOS with VNC Fails



  • QtCreator on TinkerOS with VNC Fails

    I have installed QT (using the procedure below) on a Tinker Board S running TinkerOS_Debian v2.0.7. Everything works fine connected directly to an HDMI monitor, however when I configure it for headless operation (running vncserver on the tinkerboard and a VNC viewer on my PC) I can't get qtcreator to start. I really need to run this as a remote desktop with VNC - can someone please provide a fix?

    Qt Install Procedure:
    sudo apt-get install qt5-default
    sudo apt-get install qtcreator
    sudo apt-get install qtdeclarative5-dev
    sudo apt-get install qtbase5-examples
    sudo apt-get install qtbase5-doc-html

    Error when I run "qtcreator" in a terminal (from the remote VNC desktop):
    Qt: XKEYBOARD extension not present on the X server.
    The X11 connection broke: Unsupported extension used (code 2)
    XIO: fatal IO error 11 (Resource temporaryily unavailable) on X server "1.0"

    Note: I have all this working perfectly on a RPi 3 B+ using the same configuration with no fuss or problems. So what is different or missing from the TinkerOS_Debian? Or has it something to do with the Tinker's GPU / hardware acceleration maybe? And BTW, I also tried TinkerOS_Debian v2.0.5 and Armbian Bionic 4.14 and got the same results - qtcreator will not load from a VNC remote desktop; and none of the apps I create with Qt run either (i.e. they run perfect when connected direct to an HDMI monitor, but won't launch through a VNC remote desktop).

    Other things I've tried: tightvncserver (on the tinker), TightVNC and realVNC viewers (on the PC) --> no difference.
    Note: I don't know if this is related, but after I do my initial sudo apt-get update/upgrade the built-in Chrome browser does the same thing - i.e. crashes as soon as it's launched (both on the HDMI and the remote VNC desktop).
    P.S. My Unix/Linux knowledge is limited and a bit rusty, so if you have a suggestion please be very specific.

    Thanks for the help!


Log in to reply