Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Android tab missing in QtCreator -> Tools -> Options -> Devices



  • I aim to develop a QML application for Android, while working on the operating system Windows 10. I've installed all kits needed for Android development (Android Studio, JDK 1.8.0, Android SDK and NDK r17b). I've installed Qt5.11.2 and Qt5.12.0 beta1, including all components (Android, MinGW, MSVC15/17, UWP) and including the QtCreator IDEs 4.7.1 and 4.8.0 beta1. I tried to follow this tutorial. Unfortunately my QtCreator installation is missing the Android tab (as you can see in the picture below).

    0_1539855717282_Options.PNG

    QtCreator (both, 4.7 and 4.8) just detects MinGW, UWP and MSVC kits, the Android kit is not recognized. It's frustrating, because I'm working on resolving this issue for half a week now and don't seem to make any progress.

    Can anybody help me?

    Best regards,
    Nici



  • @artsydog

    What do you see under "Kits" (in the same pane at top)?
    What is under the tabs "Kits", "Qt Versions" and "Compilers"?

    Did you see these guidelines?

    It is recommended to follow closely the different versions of Android tools. You may need to down-grade NDK



  • @koahnig
    Here are three screenshots of my the "Kits" section:

    0_1539859690587_Kits.PNG
    2_1539859653615_Versions.PNG
    0_1539859653615_Compilers.PNG

    I already followed almost all of these guidelines (except the recommended NDK 10). Before attempting to install Qt5.12 beta, everything worked fine with this setup. After the installation, there is not a single Android kit detected. Reverting back to the initial situation doesn't help, still no Android kits detected.


  • Qt Champions 2019

    @artsydog You don't have any Android version of Qt and you do not have C++ compiler for Android.



  • @jsulm I know what I'm missing, I just don't know why it's not there. Having the right setup it's supposed to be detected automatically, right? I'm just asking, because manually adding these things does not let the missing Android tab appear magically. Hence, I can not select "Android" as device when adding a kit manually.



  • @artsydog

    How did you install Qt version pre-built for Android?

    When using the MaintenanceTool should have an automatic detection like this, but for teh version you have installed:
    0_1540192816788_a498cd83-87e4-433b-badd-77d8f3ee5d29-image.png

    When the auto dectection fails, add the wt version manually by selecting the qmake in the bin-folder of installed Android pre-built. You show a trial, but could you select the qmake?



  • @koahnig I selected the Android toolkit in the Maintenance Tool of Qt. I can add the Qt versions manually by adding the path to their qmake, but they request a supported compiler, which I already tried to add by adding the path to the NDK g++/gcc.exe. Seems like there is another ABI detected than needed by the Qt versions. That's why the manually added Qt versions have a "stop sign" beside them.



  • I just opened the MaintenanceTool and got informed about my Qt installation being corrupted and that I should consider reinstalling it completely, which I have done already multiple times. But I'll try one more time and see what happens.



  • The Android Device Tab comes with qt creator as a plugin so to enable it you click on HELP->ABOUT_PLUGINS
    under the device section TICK Android to enable it in QtCreator .


Log in to reply