FakeVim clipboard commands?



  • Hi, I haven't been successful in trying to tell Qt Creator to cut/copy/paste text using the clipboard in FakeVim mode. Ctrl+X/C/V don't work and neither do "+p/y/d or "*p/y/d. I have to go to the Edit menu. Also there's the possibility of binding :paste, :cut and :copy ex commands, but that's just quirky. Is there something else I'm missing or should I file a bugreport?

    Qt Creator 2.1.0 @ Ubuntu

    Thanks.



  • You should learn Vim to work it out. A learning curve is steep but it's worth it.

    copy - y
    cut - either in visual mode use x to cut whole part into the buffer or just to cut a current char under cursor
    paste - p

    Vim rocks.

    God bless,
    Sergey.



  • No, Sergey, you don't get it. These don't use the system (Xorg) clipboard.



  • Oh, I'm sorry, didn't mind it...
    But, if you let fakevim bypass control keystrokes (there is an option there in settings - "Pass control key") then you may use editor's shortcuts with fakevim. Consider, they use system clipboard. Maybe not exactly what we should to be but better than nothing.
    Otherwise, I think I know no more than you. :)

    --
    Truly Yours,
    Sergey.



  • Perhaps put it on bugreports.qt.nokia.com


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.