Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Error 129



  • I am basically getting the exact same error as found in this thread from four months ago.

    https://forum.qt.io/topic/91714/error-install_target-error-129

    I was wondering if anybody had any insight as to what the problem might be?

    Here is the error I get in all it's glory,

    21:04:40: Starting: "C:\android-ndk-r10e\prebuilt\windows-x86_64\bin\make.exe" "INSTALL_ROOT=C:/Qt/Examples/Qt-5.11.2/widgets/itemviews/build-addressbook-Android_Release/android-build" install
    0 [main] sh 13868 sync_with_child: child 11908(0x1B4) died before initialization with status code 0xC0000142
    18 [main] sh 13868 sync_with_child: *** child state waiting for longjmp
    /usr/bin/sh: fork: Resource temporarily unavailable
    make: *** [install_target] Error 129
    21:04:41: The process "C:\android-ndk-r10e\prebuilt\windows-x86_64\bin\make.exe" exited with code 2.
    Error while building/deploying project addressbook (kit: Android for x86 (GCC 4.9, Qt 5.11.2 for Android x86))
    When executing step "Copy application data"

    I just installed QT 5.11
    creator 4.7

    Android Studio 3.2
    SDK Platform 28.0
    NDK 10e
    JDK 1.81

    I must admit having a bit of trouble getting this to run.

    The emulator starts, but as can be seen it never deploys the application to the emulator.

    A simple application does run in the emulator from Android Studio.

    I have tried searching for a similar error with '/usr/bin/sh' but honestly no luck.

    Any input would be appreciated. Thanks.





  • Thanks so much for putting me in the right 'path'. haha!!

    The problem wasn't AVRDude it seems like it was with some other games that I installed for my kids, pesky kids.


Log in to reply