Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qtcreator 4.5.2 Ubuntu 18, Bare metal



  • I am following couple of links and I end up with no warnings and or errors in the whole setup process.
    When I start debugger noting happen.
    If I disable start openocd and I start it manually, i can connect to running gdb but all the breakpoints are all over the place.
    I have the screen shots posted here.
    What I am doing wrong

    Baremetal config

    6_1538498019058_qt-baremetal.png

    build and run config

    5_1538498019058_qt-debuger.png

    compiler config

    4_1538498019058_qt-compilers.png

    kits config

    3_1538498019058_qt-kits.png 2_1538498019058_qt-deb.png

    run as debug config selected last option
    1_1538498019058_qt-runsett.png

    debugging, starts & stops
    0_1538498019058_qt-start-finfished.png



  • Use latest QtC



  • Updated form qt website. -> qt-unified-linux-x64-3.0.5-online.run

    At: http://doc.qt.io/qtcreator/creator-developing-baremetal.html
    Select Tools > Options > Devices > Add > Bare Metal Device > Start Wizard::
    there is no Start Wizard: ?!?!?!
    Though I pressed Add. and have what is already seen in first post

    then
    7. Select Projects > Build & Run and there is a picture there alt text
    Which mt IDE does not lead to same settings., anyway
    the add option (debug)

    0_1538666685315_31610873-f6e7-41cb-a6a5-24943d6946bb-image.png

    PRESS DEBUG
    11:35:03: Running steps for project s2w10lqt...
    11:35:03: Starting: "/usr/bin/make" all << why is starting this when
    make: Nothing to be done for 'all'.
    11:35:03: The process "/usr/bin/make" exited normally.
    11:35:03: Elapsed time: 00:00.

    Any workaround ?

    0_1538664462855_b5da973e-a8fb-4a10-b898-4274d060418e-image.png



  • SOLVED
    Finally got it to work.
    I installed st-util and used as a bare-metal device that instead OpenOCD,
    thuogh, I have to press Run and not Debug, with a breakpoint on main.

    With all the hassle I prefer to use Qt IDE (the only decent IDE that RUNS under Linux.)


  • Lifetime Qt Champion

    Hi @comarius,

    glad you found a solution. So please mark this topic as SOLVED with the button "Topic Tools". Thanks!


Log in to reply