Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

QLowEnergyService never completes discovery



  • I'm updating some old code that I wrote in QtQuick 5.8.0 for both android and iOS. I've recently updated to QtQuick5.11.1 and one of my QLowEnergyService objects never reaches the discovered state after I run DiscoverDetails() on iOS (works fine on Android). It also works fin for my other QLowEnergyService.

    I get a signal when it goes to the 'Discovering Services' state, but never get another signal for the discovered state. When I subsequently try to write a characteristic, it throws an operation error (as you might expect if it hasn't reached the discovered state).

    Has anyone encountered an issue like this?



  • I found a work around for this problem by reverting to Qt 5.10.2.


  • Moderators

    Have you tried with 5.11.2? I'm thinking about upgrading from 5.10.1, but if this issue is still in 5.11.2 then there is no point.



  • Yes, it was still there. I will say that one of my services worked fine, it was just one service that wasn't working for some reason and this one only had an issue on iOS.


  • Moderators

    Thanks for info



  • This post is deleted!

Log in to reply