Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Problems with the last update ot Qt (5.11.2) and msvc kits



  • Hello,

    Since the update to Qt 5.11.2 and Qt Creator 4.7.1, Qt Creator no longer finds MSVC compilation kits.

    I have to define the kits "by hand" but I have compilation problems with some projects. Strangely, on another machine that also runs on Windows 10, the update did not disturb anything....
    I don't see any errors in the environment variables,

    Here is what I defined as parameters for the msvc 2017 x64 compiler

    ![alt text](0_1537878417484_Sans titre-1.jpg image url)

    How to solve this?

    Best regards,

    Franck


  • Moderators

    Hi @Francky033

    This can happen if Qt Creator was running when the update happened as it will potentially fail to add the kits. One option is to uninstall Qt Creator and install it again to see if this helps. Or at least removing/readding the Qt version in question as that should also help force the kits to be updated. Does this help?



  • Hello AndyS and thank you for your answer....

    I tried to uninstall and then reinstall Visual Studio 2017 and Qt 5.11.2 and clean up the Windows registry but nothing works.

    The projects that are defined with Cmake do not compile normally.

    I also tried to run the bat file vcvarsamd64_x86.bat before running qtcreator and compiling assimp, but I get a lot of anomalies when I run CMake

    The output was:
    2
    Compilateur d'optimisation Microsoft (R) C/C++ version��15.26730 pour x64
    Copyright (C) Microsoft Corporation. Tous droits róervó.
    
    CMakeCXXCompilerId.cpp
    Microsoft (R) Incremental Linker Version 14.15.26730.0
    Copyright (C) Microsoft Corporation.  All rights reserved.
    
    /out:CMakeCXXCompilerId.exe 
    CMakeCXXCompilerId.obj 
    LINK : error LNK2001: symbole externe non r괯lu mainCRTStartup
    E:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC\Tools\MSVC\14.15.26726\lib\x86\LIBCMT.lib : warning LNK4272: type d'ordinateur biblioth鲵e 'x86' en conflit avec le type d'ordinateur cible 'x64'
    CMakeCXXCompilerId.exe : fatal error LNK1120: 1 externes non r괯lus
    
    
    Determining if the C compiler works failed with the following output:
    Change Dir: C:/Users/Karl Hal/AppData/Local/Temp/QtCreator-ktqLip/qtc-cmake-OnnCEveM/CMakeFiles/CMakeTmp
    
    Run Build Command:"jom" "/nologo" "cmTC_36d13\fast"
    Le fichier spécifié est introuvable
    Generator: execution of make failed. Make command was: "jom" "/nologo" "cmTC_36d13\fast"
    
    

    Thanks!



  • Is there a log file that qtcreator produces at startup that will indicate any errors when activating the kits?


  • Moderators

    Hi @Francky033

    In this case it seems to be building for 32bit whereas Qt is 64bit based in the building case. So you should use the vcvars64.bat file to get the right environment there.

    As for the Qt Creator and kits issue, I don't know what is causing that so hopefully someone else is able to figure that one out.



  • Thanx AndyS !

    I just tried it with vcvars64.bat but I have the same result.
    I don't understand it...
    But above all, how can we explain that QtCreator is not able to set up automatically the Msvc and Android kits?

    I also updated my version of Visual Studio. Can this explain this?

    I put these parameters manually to define the msvc kits. Are they correct?

    0_1537962714476_qtcreator.jpg

    Thank you!


Log in to reply