Nokia N8 and the QtSDK



  • Hi,

    I've installed the QtSDK for Nokia devices (symbian and maemo). I can compile and run everything in the simulator.

    When I compile for gcce debug and try to run on a Nokia N8 I get a "General OS Error" when QtCreator is trying to install the sis file on device. If I take the sis and install it manually it works just fine!

    I installed the TRK for Symbian^3 and both QtCreator and The device tells me that everything is OK (i.e. they are connected).

    I thought at first that it was a problem that the SDK for Symbian used in the QtSDK is too old (5th ed.) so I tried to download and install the Symbian^3 SDK and make that work in QtCreator without success. Cannot make it compile my apps. Should it just work with the embedded SDK (in QtSDK) or is the Symbian^3 SDK mandatory?

    Can anyone help me with this?


  • Moderators

    First of: Which version of TRK are you using? There is a special one for the N8 and the 5th edition TRK is known to not work. If changing TRK does not help, please try with a recent snapshot of Qt Creator.

    I would recommend sticking with the 5th edition SDK for now as the Symbian 3 SDK beta still has some warts with regards to Qt at this time.



  • [quote author="Tobias Hunger" date="1285060176"]First of: Which version of TRK are you using? There is a special one for the N8 and the 5th edition TRK is known to not work. If changing TRK does not help, please try with a recent snapshot of Qt Creator.

    I would recommend sticking with the 5th edition SDK for now as the Symbian 3 SDK beta still has some warts with regards to Qt at this time.[/quote]

    Where do you get one for N8?



  • If you install the newest (i think it's 1.0.1) Nokia Qt SDK for Windows, you get also a TRK for Symbian 3.



  • How can i install the qt libs on nokia n8 now??
    i have updated qt sdk and installed qt_mobility_symbian^3.sis on my phone.
    the installation of the qt_installer.sis does not work (error -10256).
    my apps dont start on phone.



  • Well, Matze5590 I ran into the same problem. So, this a very important issue and didn't get any clue how to fix this. The qt_installer.sis is the missing point in the setup. I hope I'll get any answers.



  • The initial post refers to a “General OS Error”. Have you confirmed this isn't a signing issue? I wrote a "short blog post":http://kerncomputing.blogspot.com/2010/06/tech-tip-signing-and-qt-apps.html about trouble shooting them.

    -jk



  • Well, even if I had an application it would require the qt libs. So I followed the instructions to set up a proper environment for my N8. And within this process I stumble over the above described issue with the sis-package of the qt libraries. So, no, I don't think this is a signing issue.



  • well i got the same error just now and then I discovered that I was trying to install my app on to mass memory. I installed to c: on device and it works fine. I think this is not right ... I should be able to install on mass memory too... else I'll run out of space on c: :(

    I'm using TRK for Symbian^3, but compiling using S60 SDK 5th edition. Still not able to properly compile using Symbian^3 SDK .. currently trying to get that working



  • well at least i figured out the first issue, my own fault ... you can specify the installation drive in run settings, and the app should be then installed in the same drive when it prompts for in the device ... so now no longer bound to c: ... and not getting the "general os error" too



  • hi,
    how i can specify the installation drive in run settings,its is configured default already.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.