Important: Please read the Qt Code of Conduct -

Qt Android, can't compile for API 10

  • Hi, trying to compile for gingerbread 2.3.5 or higher, but i keep getting this message:
    The API level set for the APK is less than the minimum required by the kit.
    The minimum API level required by the kit is 16.
    Error while building/deploying project untitled2 (kit: Android for x86 (GCC 4.9, Qt 5.11.1 for Android x86))
    When executing step "Build Android APK"

    despite having set the android manifest to minimum required sdk to api 10, target sdk 10 and inside build settings, android sdk build: 10.

    when i compile for lets say api 26 it works. 3 days now not trying to make this thing run.... this used to be easier to configure back in 2015....

    I'm using Qt 5.11.1 Win 10 32 bit, SDK 26, NDK r17b / r10e

  • Lifetime Qt Champion


    As the error message says: the minimal required API version is 16.

    If you need lower version, then you have to use an older version of Qt.

  • @SGaist Older version of Qt? pls explain. So i'm fine using the latest SKD and NDK from android even if i use Qt 4.8 right?

  • Lifetime Qt Champion

    No, stay with Qt 5. Qt 4 has reached end of life a long time ago.

    It's explained here. Basically, if you are targeting such old versions of Android, you'll likely have to use Qt 5.6.

Log in to reply