Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Qml aplication not show when run in xinit



  • Hello,
    I have embedded device base on debian. I used widget aplication. It starts throught xinit (.xinitrc).

    Now I rewrite aplication to QML. When I run xinit, nothing is shown - black screen.
    Console output is normal (no error).

    I installed xfce4 only for testing. I run xfce4 and than run my aplication in xterm, everything is correct displayed.

    There is some diference when run widget or qml aplication by xinit? Need I set some env variable?

    Thank for help!



  • Ok, when you use xinit (X11) you used xcb platform driver.
    In documentation there is:

    XCB
    Note: On some devices there is no EGL and OpenGL support available under X because the EGL implementation is not compatible with Xlib. In this case the XCB plugin is built without EGL support, meaning that Qt Quick 2 or other OpenGL-based applications does not work with this platform plugin. It can still be used however to run software-rendered applications (based on QWidget for example).

    When I used linuxfb plugin, it works coretly.

    When I tryed eglfs:

    ./test_program -platform eglfs
     void DEBUG_init() 	  Debug disable
    libEGL warning: DRI3: xcb_connect failed
    libEGL warning: DRI2: xcb_connect failed
    libEGL warning: DRI2: xcb_connect failed
    Could not initialize egl display
    Neúspěšně ukončen (SIGABRT)
    

    I have all opengl library (I hope).
    What does it mean?

    Thanks.


Log in to reply