Deployment on Windows will not run, no error, no idea, help!?!



  • Hello. I am new to Qt and trying to create a Windows deployment. I started here...
    http://wiki.qt.io/Deploy_an_Application_on_Windows

    I am building an ESRI ArcGIS 100.2.1 QML based app which uses MSVC2017 on a 64 bit machine running Windows 7. The application builds and runs fine within Qt Creator.

    I tried the "Quick and dirty" section of the above deployment instructions and when I double click my exe, I get nothing. I don't even see a glimpse of a window or app start up. My mouse cursor just briefly changes, then nothing. The path of the bin/plugins/qml files and folders are slightly different than the instructions in "Quick and dirty" as I used the folders specific to MSVC2017. So I coped from the following to the location of my deployment folder where my exe is...
    C:\Qt\5.10.0\msvc2017_64

    Anyway....how can I troubleshoot this? Any help is appreciated. Let me know if any more info would help. Thanks!


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    What about using windeployqt ?



  • Yeah, I tried windeployqt too. Same result. I did see that warning at the top about VCINSTALLDIR. I tried setting that within my command prompt session to the following...
    C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\VC

    Then rerunning windeployqt the warning went away, but still same result. I'm not 100% if the above path is what I should have set it to or if the warning even really matters. Attached is a screenshot...
    0_1525722966238_Capture1.JPG


  • Lifetime Qt Champion

    Looks like you are using QML but you don't use the --qmldir option so you won't have the proper QML dependencies deployed.



  • @SGaist thanks for that tip. I reran passing the qmldir option and same result. Still the app doesn't load. I guess it doesn't surprise me though since the "Quick and dirty" method suggested copying the QML directory manually, which I did then, and still no go. Attached is a screen shot of the command I ran and I redirected the output to a log file (had to since it was too much to include in just one screen shot). Thanks so much for helping.0_1525724698640_Capture2.JPG
    I'll try attaching the log file shortly. It is giving me a permissions error at the moment. Maybe I have to make a 2nd post.


  • Lifetime Qt Champion

    That warning could explain why it's not working.

    Did you try to deploy using Visual Studio command prompt ?



  • Actually, previously I had not. Thanks for that tip. I am learning as I go :)

    But now I have run the same commands from "Developer command prompt for VS", and the warning goes away. But still to no avail. Executing my EXE does nothing. No window or error. I still don't have permissions to upload the entire log file here, so I'll add a couple screen shots. First one is beginning of log, second is end of log.
    0_1525726950048_Capture4.JPG 0_1525727011916_Capture5.JPG

    This is my deploy directory afterwards...
    0_1525727117098_Capture6.JPG


  • Lifetime Qt Champion

    Qt5Test.dll ? That's fishy... This is not a module that should be used in anything else that tests.

    What I would do first is just try to deploy a default QWidget application, once that done and working, I'd go for a default QtQuick application just to be sure the procedure goes as expected.



  • Thanks for the help on this. Ultimately doing the QtQuick app and seeing that it worked, led me down a path searching for what was missing that was required by the ArcGIS templated project. Even though dependency walker didn't find anything and I did not see any documentation on ESRI's site about dependencies, I was able to slowly work my way through what looked like missing DLLs and once I had them included, the app loaded.



  • @JrDeskJockey if your issue is solved, please don't forget to mark your post as such. Thanks.


  • Lifetime Qt Champion

    Glad you found out !

    Can you share what was missing ?



  • Sure. I had to visually compare a samples app from ESRI and copy over what I thought was missing. This is what worked for me.....including these additional files...
    C:\Program Files (x86)\ArcGIS SDKs\Qt100.2.1\sdk\windows\x64\bin\release\EsriCommonQt.dll
    C:\Program Files (x86)\ArcGIS SDKs\Qt100.2.1\sdk\windows\x64\bin\release\runtimecore.dll
    C:\Program Files (x86)\ArcGIS SDKs\Qt100.2.1\sdk\windows\x64\bin\release\ArcGISRuntimeToolkitCppApi.dll
    C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\Remote Debugger\x64\msvcp140.dll
    C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\Remote Debugger\x64\vcruntime140.dll
    C:\Qt\5.10.0\msvc2017_64\bin*.dll


  • Lifetime Qt Champion

    Thanks !


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.