Important: Please read the Qt Code of Conduct - https://forum.qt.io/topic/113070/qt-code-of-conduct

Problem with building basic shapes example



  • Hi all,

    I've just installed the Qt 5.10.1 and tried to build and run the basic shapes example with some staff of Qt 3D but it's crashing returning the error:
    0_1524219866843_23cfdab8-bc9f-4d5f-8e8b-8b7fe4903c32-image.png

    Previously I had version 5.9.1 and there was no problem.
    For building I use MSVC2015 64bit. see details below:
    0_1524220074121_539c7385-c471-46b4-8543-18a42eb7ad70-image.png

    Please if you have any ideas for help, I would appreciate it very much.


  • Lifetime Qt Champion

    @Dimis "division by zero"?! You should start with debugger and go step by step to see where exactly it crashes.



  • It's the original code of the example without any modification. Is it possible this? I suspect something else goes wrong, because I have the same problem with some other examples which have Qt3D class used.


  • Lifetime Qt Champion

    @Dimis
    Hi
    If you just load a .pro file and it then crashes from the include example projects
    i would suspect driver issue or something like that.
    You could try to check your gfx driver is up to date.

    Older intel hd 2000/3000/4000 gave me all kind of strange errors with openGl.
    So keep this in mind if using an older laptop.



  • @mrjj Indeed I have an old computer and my gfx card is intel 3000 however before the installing the new version of Qt it was working.
    I can't really understand what's happening...


  • Lifetime Qt Champion

    @Dimis
    Hi
    Newer version of Qt might have higher expectations of the openGL level/support.
    Did you check if new driver was available ?



  • @mrjj yeap, no updated available. I've got the latest one, dated back to June 2016. So do I need to go back to the 5.9 version of Qt?


  • Lifetime Qt Champion

    @Dimis
    it does sounds new enough but hard to tell.
    It would be good test to install 5.9 and see if it just works.
    Could be something else but if it runs in 5.9, its most likely related to
    openGL version.
    http://doc.qt.io/qt-5/windows-requirements.html
    Seems to want minimum OpenGL 2.1
    Does intel docs says what version driver provides?



  • Just installed 5.9.1 again. The example builds and runs but when I close it it hits this error:

    QWindowsWindow::setGeometry: Unable to set geometry 1200x800+363+129 on QWidgetWindow/'QWidgetClassWindow'. Resulting geometry: 1200x749+363+129 (frame: 8, 31, 8, 8, custom margin: 0, 0, 0, 0, minimum size: 427x201, maximum size: 16777215x16777215).
    Assertion failed!

    Program: C:\Qt_Suite\5.9\5.9.1\msvc2015_64\bin\libGLESv2d.dll
    File: ......\3rdparty\angle\src\libANGLE\r...\SurfaceD3D.cpp
    Line: 258

    Expression: false

    For information on how your program can cause an assertion
    failure, see the Visual C++ documentation on asserts

    (Press Retry to debug the application - JIT must be enabled)

    Any ideas?



  • Hi all again,

    I've just come to a conclusion regarding my issue and fixed it somehow.
    Probably I had mixed up the compilers MSVC 2015 so I uninstall everything and isntall it again version 5.9.1. At least now everything is working, but with the following errors that appear after I've stopped debugging the example:

    QWindowsEGLContext::makeCurrent: Failed to make surface current. eglError: 300d, this: 0x20180aba1e0
    Qt3D.Renderer.Backend: bool __cdecl Qt3DRender::Render::GraphicsContext::makeCurrent(class QSurface *) makeCurrent failed

    QOpenGLContext::swapBuffers() called with non-exposed window, behavior is undefined.

    Searching for these I found that these might be caused due to a bug in this Qt version or due to my old graphics card. Also this might be a combination of these two.

    So for now no particular solution with specific steps, just uninstall and install the most proper version for the computer you have.

    Many thanks again.


Log in to reply