Unable to build project : No such file



  • Hi

    I'm working on a project for Maemo5, using the QtService objects, I have included QtService.pri, and QtCreator knows the objects, but whenever I try to build the project I get the following result :

    @Running build steps for project callloggerd...
    Configuration unchanged, skipping qmake step.
    Starting: "/usr/bin/make" -w
    make: Entering directory /home/kif/Development/PhoneLogger/CallLogger/CallLoggerd/callloggerd-build-maemo' /home/kif/NokiaQtSDK/Maemo/4.6.2/targets/fremantle-1030/bin/qmake -spec /home/kif/NokiaQtSDK/Maemo/4.6.2/sysroots/fremantle-arm-sysroot-1030-slim/usr/share/qt4/mkspecs/linux-g++-maemo5 -unix -o Makefile ../callloggerd/callloggerd.pro make: Leaving directory/home/kif/Development/PhoneLogger/CallLogger/CallLoggerd/callloggerd-build-maemo'
    make: Entering directory `/home/kif/Development/PhoneLogger/CallLogger/CallLoggerd/callloggerd-build-maemo'
    g++ -c -pipe -O3 -fno-omit-frame-pointer -fno-optimize-sibling-calls -Wall -W -D_REENTRANT -DQT_GL_NO_SCISSOR_TEST -DQT_DEFAULT_TEXTURE_GLYPH_CACHE_WIDTH=1024 -DQT_NO_DEBUG -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -I/home/kif/NokiaQtSDK/Maemo/4.6.2/sysroots/fremantle-arm-sysroot-1030-slim/usr/share/qt4/mkspecs/linux-g++-maemo5 -I../callloggerd -I/home/kif/NokiaQtSDK/Maemo/4.6.2/sysroots/fremantle-arm-sysroot-1030-slim/usr/include/QtCore -I/home/kif/NokiaQtSDK/Maemo/4.6.2/sysroots/fremantle-arm-sysroot-1030-slim/usr/include/QtNetwork -I/home/kif/NokiaQtSDK/Maemo/4.6.2/sysroots/fremantle-arm-sysroot-1030-slim/usr/include -I/home/kif/NokiaQtSDK/QtService/src -I. -I../callloggerd -I. -o callloggerdaemon.o ../callloggerd/callloggerdaemon.cpp
    In file included from ../callloggerd/callloggerdaemon.cpp:1:
    ../callloggerd/callloggerdaemon.h:4:23: error: qtservice.h: No such file or directory
    @

    The source (including the .h files are located at /home/kif/NokiaQtSDK/QtService/src

    I have tried adding LIB += and LIBS += to the .PRO file with no difference.

    I am fairly sure I have seen this problem before, but I cannot remember what the solution was, can anyone here help ?

    Kim



  • If I understood it correctly, your problem is that the compiler can't find a header you include and is not in the default include paths. Did you try to add this path to INCLUDEPATH variable in your .pro?



  • Hi anselmolsm

    Yes, I have also tried with INCLUDEPATH+=, with the same result.

    In both cases the location of the .h files (/home/kif/NokiaQtSDK/QtService/src) is part of the g++ line of the compiler output.

    Kim


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.