Qt 5.10.1 Bluetooth examples on classic windows fail to start



  • https://doc.qt.io/qt-5.10/qtbluetooth-index.html details that there is no Bluetooth support for the Windows Qt 5.10.1 port, which is fine for us, however the Qt Bluetooth (classic) examples used to start using older versions of Qt on Windows 7.
    Note this is when the application is build with Visual Studio (2015 32bit), not when it is build with MinGW.
    The applications build with 5.10 seem to fail because the depend on an UWP packages, a packages that is of course not available on Windows 7. The depends tool is indicating that API-MS-WIN-CORE-WINRT-L1-1-0.dll etc are missing...

    Could someone confirm the dummy backend of the Windows port was replaced by some UWP depended implementation? (If so, I assume it not yet an officially supported Qt Bluetooth option, as it is not documented on the https://doc.qt.io/qt-5.10/qtbluetooth-index.html page)


  • Moderators

    @HansVL
    nope, thats conform with my 10.1 experience