Polish letters in issues panel errors/warnings not showing up



  • Hello everyone!
    I am currently creating a small qml application and I've stumbled upon a little annoyance that I am not sure how to deal with. Whenever there are some warnings or errors after building, the messages shown in Issues panel in Qt Creator are missing polish letters. For example, in the second warning there is "kt˘rego" instead of "którego".

    alt text
    This is not some big problem but it is annoying. Can someone please help me fix it?


  • Qt Champions 2017

    Hi @Ilethas,

    this is a long known problem, please see QTCREATORBUG-316 for possible workarounds.

    Regards


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Can you show the related code ?
    Also, can you translate the error in english ?



  • Sure!

    C4100: "renderer": parametr formalny, do kt˘rego nie istnieje odwoˆanie
    C4100: "win": parametr formalny, do kt˘rego nie istnieje odwoˆanie
    LNK4042: obiekt określono więcej niż raz; dodatkowe wystąpienia zostały zignorowane

    would be:

    C4100: "renderer": unreferenced formal parameter
    C4100: "win": unreferenced formal parameter
    LNK4042: object specified more than once; extras ignored

    The first two warnings are caused by the code below. The functions are temporarily empty and their parameters aren't used yet and give warnings.

    void TutorialOpenGLView::setRenderer(TutorialRenderer* renderer)
    {
    
    }
    
    void TutorialOpenGLView::handleWindowChanged(QQuickWindow *win)
    {
    
    }
    

    I am not sure what causes the last warning, it just happens after I rebuild my project. Maybe this could be because of my build configuration? After double clicking warning message, it just redirects me to some disassembly in main.obj
    alt text


  • Lifetime Qt Champion

    For the first two warnings, you can either comment out the parameter name or use Q_UNUSED.

    As for the last one, do you have multiple source files with the same name ?



  • Sorry for long delay!

    I managed to get english warning/error messages by uninstalling polish language pack for visual studio 2017 and leaving english as the only language. I guess Qt Creator just tried to use OS language for the messages even if UI language was set to something else. Other method that worked for me was to create a shortcut forcing Creator to use english:

    C:\Windows\System32\cmd.exe /c "set ^"VSLANG=1033^" && start C:\Qt\Tools\QtCreator\bin\qtcreator.exe"
    

    As for the warnings, I've dealt with the first two (never knew about the Q_UNUSED, that's handy!). The last one is visible even if no project is opened, in "Build & run -> Kits -> Desktop (default)". I wanted to use compiler that comes with Visual Studio 2017 to build 32-bit executables, I read that Qt built with MSVC 2015 is compatible, however the configuration shown in my last screenshot gives warning that my compiler may not produce compatible code.

    Edit: So, according to QTCREATORBUG-17740 I technically shouldn't worry about this warning? My program runs without problems on this configuration, I just don't like ignoring warnings. After all, they are for a reason, right? :)


  • Lifetime Qt Champion

    Technically VS2017 is backward compatible with VS2015 but who knows what may break in a futur update ^^



  • Hm, so if I wanted to be super-safe I should compile Qt myself with MSVC 2017 32-bit and use that, right? I think for now, while it works, I'll stick with Qt compiled with MSVC 2015 and use MSVC 2017. Thank you @SGaist and @aha_1980 for helping me!


  • Lifetime Qt Champion

    For super super safe, indeed. But you shouldn't need to so go on as you are currently :)


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.