Nominate our 2022 Qt Champions!

Breakpoint with hourglass

  • Hello everybody,
    I have an issue in the following configuration.

    • QTcreator 4.5.1, based on QT 5.10.1 (MSVC 2015, 32 bit)
    • Windows 7 PC
    • CDB installed from Windos SDK (versione 6.12.0002.633, ABI x86-windows-msvc2010-pe-32bit)
    • Compiler: MSVC 9.0 (both 64 and 32 bit)
    • QT 4.8.5 x86

    I'm able to build the project, but I fail running the DEBUG. I built the code using the Debug configuration, and here is the generated CLI on te compile output panel:

    	C:\Qt\qtcreator-4.5.1\bin\jom.exe -f Makefile.Debug
    	cl -c -nologo -Zm200 -Zc:wchar_t- -Zi -MDd -GR -EHsc -W3 -w34100 -w34189 -DUNICODE -DWIN32 -I"..\test_2" -I"." -I"..\..\..\..\Qt\4.8.5_x86\mkspecs\win32-msvc2008" -Fodebug\ @C:\Users\parodig.EDG\AppData\Local\Temp\main.obj.6032.16.jom
    	link /NOLOGO /DYNAMICBASE /NXCOMPAT /DEBUG /SUBSYSTEM:CONSOLE "/MANIFESTDEPENDENCY:type='win32' name='Microsoft.Windows.Common-Controls' version='' publicKeyToken='6595b64144ccf1df' language='*' processorArchitecture='*'" /MANIFEST /MANIFESTFILE:"debug\test_2.intermediate.manifest" /OUT:debug\test_2.exe @C:\Users\parodig.EDG\AppData\Local\Temp\test_2.exe.6032.1623.jom
    	mt.exe -nologo -manifest "debug\test_2.intermediate.manifest" -outputresource:debug\test_2.exe;1

    Any breakpoint on the code appears as a red bullet with an hourglass on it and the code do not break at it.
    The debug output panel is at the following link:

    Link to debug output, pastebin

    The source code is a simple hello world automatically generated by QtCreator

    Any help will be appreciated.

    Best regards

  • Lifetime Qt Champion


    Out of curiosity, are you locked to these old versions of Qt and compiler ?

  • Hi @SGaist thank you for yoyr reply.
    I have to use the MSVC 2008 because of a license company issue.

    However, if needed, I can upgrade the QT library.
    Do you think there is some issue related to my MSVC compiler?
    Is there any bug already traced on the web? I was not able to find any document about this, but any help culd be useful.

    Finally, I have a question, do you know why, on the kit panel, QtCreator suggests to use the CDB 64 bit, while I'm using a QT library version built for x86? I tried both CDB 64 and 32 bit, but I wasn't able to fix the issue.

  • Lifetime Qt Champion

    I'd go with at least Qt 4.8.7 since it's the latest and last of that series if you can't upgrade to Qt 5.

    No I don't but I'd check the value of the compiler used within that kit.

  • Lifetime Qt Champion

    hi @Giox79, from your debugger log I see that Creator wants to start a 64 bit CDB. so you should check your settings.

    Regarding the old versions: I still use Qt 4.8.2 with MSVC 2010 and Creator 4.5, so your setup is not too exotic. I guess after correcting the settings it will work.

  • Hi @aha_1980 thank you for your help.
    I tried uninstalling the x86 Debugging tools for Windows and installing the 64 bit one but I'm not able to fix the issue.

    I found, I think, an interesting news.
    Looking at the "Debugger log" panel, as soon as I place a breakpoint on the source code, the text:


    appears, and nothing happens.
    May be this can help to better understand the issue?

    Tomorrow I will try updating the QT version as suggested by @SGaist

  • Lifetime Qt Champion

    Hi @Giox79:

    Hi @aha_1980 thank you for your help.
    I tried uninstalling the x86 Debugging tools for Windows and installing the 64 bit one but I'm not able to fix the issue.

    No, you misunderstood me :(

    Look in your debugger log, line 7: dDebugger: C:\Program Files\Debugging Tools for Windows (x64)\cdb.exe: That clearly indicates a 64 bit debugger. As you said you are using a 32 bit compiler, I don't think that will work.

    What do you have configured in QtCreator -> Tools -> Options -> Build & Run -> Debuggers? Which debugger is assigned to your Kit (same option page, Tab Kit)?

    I don't think you need to reinstall Qt.

  • Hi @aha_1980 thank you for your help.
    I installed the 32 bit version of the debugger.
    I think everything is fine, but nothing works fine...


    Once again, I'm able to compile the source code, but in the debugger log I have the following output

    sStarting debugger "CdbEngine" for ABI "x86-windows-msvc2008-pe-32bit"...
    dStart parameters: 'test_2' mode: 1
    dABI: x86-windows-msvc2008-pe-32bit
    dLanguages: c++ 
    dExecutable: C:\Users\parodig.EDG\Documents\build-test_2-Desktop-Debug\debug\test_2.exe 
    dDirectory: C:\Users\parodig.EDG\Documents\build-test_2-Desktop-Debug
    dDebugger: C:\Program Files (x86)\Debugging Tools for Windows (x86)\cdb.exe
    dProject: C:\Users\parodig.EDG\Documents\test_2
    dAdditional Search Directories:
    dDebug Source Location: 
    dDebugger settings:
    dAdditionalArguments:   (default: )
    dAdjustBreakpointLocations: true  (default: true)
    dAllPluginBreakpoints: true  (default: true)
    dAlwaysAdjustColumnWidths: true  (default: true)
    dAutoDerefPointers: true  (default: true)
    dAutoEnrichParameters: true  (default: true)
    dAutoQuit: false  (default: false)
    dBreakEvent: eh  (default: )  ***
    dBreakOnAbort: false  (default: false)
    dBreakOnCatch: false  (default: false)
    dBreakOnCrtDbgReport: false  (default: false)
    dBreakOnFatal: false  (default: false)
    dBreakOnThrow: false  (default: false)
    dBreakOnWarning: false  (default: false)
    dBreakpointCorrection: true  (default: true)
    dBreakpointsFullPath: false  (default: false)
    dCDB_Console: true  (default: false)  ***
    dCloseBuffersOnExit: false  (default: false)
    dCloseMemoryBuffersOnExit: true  (default: true)
    dDisplayStringLimit: 100  (default: 100)
    dEnableReverseDebugging: false  (default: false)
    dExtraDumperFile:   (default: )
    dFontSizeFollowsEditor: false  (default: false)
    dGdbCustomDumperCommands:   (default: )
    dGdbPostAttachCommands:   (default: )
    dGdbStartupCommands:   (default: )
    dIdentifyDebugInfoPackages: false  (default: false)
    dIgnoreFirstChanceAccessViolation: false  (default: false)
    dIntelFlavor: false  (default: false)
    dLoadGdbDumpers2: false  (default: false)
    dLoadGdbInit: true  (default: true)
    dLogTimeStamps: false  (default: false)
    dMaximalStackDepth: 20  (default: 20)
    dMaximalStringLength: 10000  (default: 10000)
    dMultiInferior: false  (default: false)
    dNoPluginBreakpoints: false  (default: false)
    dQmlInspector.ShowAppOnTop: false  (default: false)
    dRaiseOnInterrupt: true  (default: true)
    dRegisterForPostMortem: false  (default: false)
    dSelectedPluginBreakpoints: false  (default: false)
    dSelectedPluginBreakpointsPattern: .*  (default: .*)
    dShowQObjectNames2: true  (default: true)
    dShowQmlObjectTree: true  (default: true)
    dShowQtNamespace: true  (default: true)
    dShowStandardNamespace: true  (default: true)
    dShowThreadNames: false  (default: false)
    dSkipKnownFrames: false  (default: false)
    dSortStructMembers: true  (default: true)
    dSourcePaths: srv*  (default: )  ***
    dStationaryEditorWhileStepping: false  (default: false)
    dSwitchModeOnExit: false  (default: false)
    dSymbolPaths: C:\TEMP\symbolcache  (default: )  ***
    dTargetAsync: false  (default: false)
    dUseAddressInBreakpointsView: false  (default: false)
    dUseAddressInStackView: false  (default: false)
    dUseAlternatingRowColours: false  (default: false)
    dUseCodeModel: true  (default: true)
    dUseDebuggingHelper: true  (default: true)
    dUseDynamicType: true  (default: true)
    dUseMessageBoxForSignals: true  (default: true)
    dUsePythonDumper: false  (default: true)  ***
    dUseToolTips: true  (default: true)
    dUseToolTipsInBreakpointsView: true  (default: false)  ***
    dUseToolTipsInBreakpointsView: true  (default: true)
    dUseToolTipsInLocalsView: false  (default: false)
    dWarnOnReleaseBuilds: true  (default: true)
    dWatchdogTimeout: 20  (default: 20)
    dState changed from DebuggerNotReady(0) to EngineSetupRequested(1) [master]
     Launching C:\Program Files (x86)\Debugging Tools for Windows (x86)\cdb.exe -aqtcreatorcdbext.dll -lines -G -c .idle_cmd !qtcreatorcdbext.idle -2 -srcpath srv* -y C:\TEMP\symbolcache C:\Users\parodig.EDG\Documents\build-test_2-Desktop-Debug\debug\test_2.exe
     using C:\Qt\qtcreator-4.5.1\lib\qtcreatorcdbext32\qtcreatorcdbext.dll of 10/02/2018 03:49.
     C:\Program Files (x86)\Debugging Tools for Windows (x86)\cdb.exe running as 8268
     Microsoft (R) Windows Debugger Version 6.12.0002.633 X86
     Using codemodel based breakpoint correction.
     Copyright (c) Microsoft Corporation. All rights reserved.
     CommandLine: C:\Users\parodig.EDG\Documents\build-test_2-Desktop-Debug\debug\test_2.exe
     Symbol search path is: C:\TEMP\symbolcache
     Executable search path is: 
    sModule loaded: test_2.exe
    sModule loaded: ntdll.dll
    sModule loaded: C:\WINDOWS\syswow64\kernel32.dll
    sModule loaded: C:\WINDOWS\syswow64\KERNELBASE.dll
    sModule loaded: C:\WINDOWS\WinSxS\x86_microsoft.vc90.debugcrt_1fc8b3b9a1e18e3b_9.0.30729.1_none_bb1f6aa1308c35eb\MSVCP90D.dll
    sModule loaded: C:\WINDOWS\WinSxS\x86_microsoft.vc90.debugcrt_1fc8b3b9a1e18e3b_9.0.30729.1_none_bb1f6aa1308c35eb\MSVCR90D.dll
     (1c78.2f6c): Break instruction exception - code 80000003 (first chance)
     eax=00000000 ebx=00000000 ecx=4e1c0000 edx=001de2a8 esi=fffffffe edi=00000000
     eip=77330fc4 esp=003efa78 ebp=003efaa4 iopl=0         nv up ei pl zr na pe nc
     cs=0023  ss=002b  ds=002b  es=002b  fs=0053  gs=002b             efl=00000246
     77330fc4 cc              int     3
     cdb: Reading initial command '.idle_cmd !qtcreatorcdbext.idle'
     Execute when idle: !qtcreatorcdbext.idle

    Thank you again for your help

  • Lifetime Qt Champion

    Hi @Giox79

    yes, now everything looks as expected.

    Please create a report at describing the problem and provide the debuggerlog there. Maybe the developer can say more to your problem ... my possibilities end here :(

  • Lifetime Qt Champion

  • @aha_1980 Thank you I forgot to link le bug that I submitted.
    Thank you again
    Have a nice day