Qt Application crashes on startup



  • So earlier today I uninstalled Visual Studio 2013 and all of its components. I am not sure if this has affected my Qt installation, but I don't know what else it should have been. Anyway, my Qt installation worked perfectly fine before, but now every time I run an (even in a newly created project) application, I always get the following output:

    Starting C:\path\to\untitled.exe...
    The program has unexpectedly finished.
    The process was ended forcefully.
    C:/path/to/untitled.exe crashed.

    However this is only when I run in debug mode, when I run in release mode it seems to work fine.

    I am using Qt 5.10.1 with MSVC 2017 64bit.
    I also have Visual Studio 2017 installed, and after uninstalling Visual Studio 2013 and all of its components I ran the "Repair" function in the VS2017 installer. I have also tried re-installing Qt but I still get the same error message when running an application in Debug mode, and I don't know what else could be wrong.


  • Lifetime Qt Champion

    Hi,

    Rather than repaire I would re-install MSVC 2017 completely to be sure it has everything needed.



  • Are you using and Intel HD Graphics video card? I've noted they broke the driver for OpenGL https://communities.intel.com/message/521599#521599 but it's a big blackhole trying to get fixed.

    If you specify:

    // MSVC17 / Intel driver bug - use angle
    QGuiApplication::setAttribute(Qt::AA_UseOpenGLES, true);
    

    before QApplication ... does that get you working?

    It's a bit shit cause I believe you lose anti-aliasing - I've just put MSVC compiler builds/branches low for now and am using GCC in linux and MinGW5.3.0 to further development.

    I'd try using another compiler just to see if you can get moving again.



  • I tried re-installing MSVC 2017 completely as SGaist said and it seems to have fixed the problem, now I can run applications in debug mode again :)

    Thanks for the help both of you!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.