Undefined symbols for architecture x86_64 - Linker error when building webrtc Qt for Mac



  • I’m trying to make a build for Mac desktiop in Qt Creator using WebRTC native library but always see the error message:

    Undefined symbols for architecture x86_64:
    "_NSOSStatusErrorDomain", referenced from:
    rtc::DescriptionFromOSStatus(int) in libwebrtc.a(logging_mac.o)
    "OBJC_CLASS$_NSError", referenced from:
    objc-class-ref in libwebrtc.a(logging_mac.o)
    "OBJC_CLASS$_NSObject", referenced from:
    objc-class-ref in libwebrtc.a(thread_darwin.o)
    "OBJC_CLASS$_NSThread", referenced from:
    objc-class-ref in libwebrtc.a(thread_darwin.o)
    "_objc_autoreleasePoolPop", referenced from:
    (anonymous namespace)::InitCocoaMultiThreading() in libwebrtc.a(thread_darwin.o)
    rtc::Thread::PreRun(void*) in libwebrtc.a(thread_darwin.o)
    rtc::Thread::ProcessMessages(int) in libwebrtc.a(thread_darwin.o) ….
    ld: symbol(s) not found for architecture x86_64
    clang: error: linker command failed with exit code 1 (use -v to see invocation)
    make: *** [lib*******_WebRTCWrapper.1.0.0.dylib] Error 1
    12:17:39: The process "/usr/bin/make" exited with code 2.
    Error while building/deploying project (kit: Desktop Qt 5.10.0 clang 64bit)
    When executing step "Make"

    Initial parameters:

    Qt Creator Based on Qt 5.10.0 (Clang 7.0 (Apple), 64 bit)
    Compiler - Clang (C++ x86 64 bit) in c++11 mode against libc++
    MacOS - Sierra v.10.12.6
    Xcode - Version 9.2 (9C40b)
    WebRTC - branch-heads/63
    After playing with compilation options of webrtc, I have compiled with system's clang and using libc++.

    I have builded the webRTC library with parameters:

    gn gen out/x64/Debug --args='is_debug=true target_os="mac" is_component_build=false rtc_include_tests=false target_cpu="x64”’
    export GYP_DEFINES="build_with_libjingle=1 build_with_chromium=0 libjingle_objc=1 clang=1 clang_xcode=1 use_system_libcxx=1 OS=mac"
    export GYP_GENERATORS="ninja, xcode-ninja"
    export GYP_DEFINES="$GYP_DEFINES OS=mac target_arch=x64"
    export GYP_GENERATOR_FLAGS="$GYP_GENERATOR_FLAGS output_dir=out/x64/Debug”
    ninja -v -C out/x64/Debug

    Moreover after extensive googling I have edited common.gypi file in /src/build/

    'xcode_settings': {
    'GCC_DYNAMIC_NO_PIC': 'NO', # No -mdynamic-no-pic
    # (Equivalent to -fPIC)
    'CLANG_CXX_LIBRARY': 'libc++',
    # MACOSX_DEPLOYMENT_TARGET maps to -mmacosx-version-min
    }

    'GCC_ENABLE_CPP_RTTI': 'YES', # -fno-rtti
    'GCC_TREAT_WARNINGS_AS_ERRORS': 'NO', # -Werror
    'CLANG_CXX_LIBRARY': 'libc++', # -stdlib=libc++

    But unfortunately, the result error is the same!!!


  • Qt Champions 2017

    Hi and welcome to the forums.
    Do you mean this ?
    https://github.com/liyouchang/webrtc-qt
    Or is it the (not qt related) code from
    https://webrtc.org/



  • It's code from https://webrtc.org/


  • Lifetime Qt Champion

    Hi,

    @Denys-Yamkovyi said in Undefined symbols for architecture x86_64 - Linker error when building webrtc Qt for Mac:

    _NSOSStatusErrorDomain

    You need to link to the Foundation framework.

    On a side note, that's a problem of webrtc not Qt, you should check with the authors of that library.



  • @SGaist I'm very appreciate for your help! You solved my problem! Thank's a lot!!


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.