Qt 5.10.0 GCC64bit - No compiler can produce code for this qtversion - x86-linux



  • Hi all,
    I'm a brand new Ubuntu user. I normally work on windows (yes, I know... It's why I try to step forward).
    After installing Qt 5.10.0 with the only compiler provided (GCC_64), I get this information in the Compile and run / Qtversions :
    auto-detected Qt 5.10.0 GCC 64bit /home/user/Qt/5.10.0/gcc_64/bin/qmake with an exclamation mark and this information : No compiler can produce code for this qtversion. Please define one or more compilers for : x86-linux-generic-elf-64bit.

    The path is correct, and the qmake file exists in this directory.

    On windows, no problem with MinGW 32.

    I missed a step, but I don't know which one, and other threads about this same topics are not relevant for me.

    I welcome help, if possible.

    Thanks



  • Hi and welcom @Kontiki,

    So, do you have a compiler /usr/bin/gcc?

    If not, please run sudo apt-get install build-essential in a terminal. This should set up at least the minimum needed tools for compiling.



  • Thanks for your help.

    I ran the command and install the build-essential. Now I have this other problem :

    /usr/bin/ld: cannot find -lGL

    Googling on this topic I found this answer : http://stackoverflow.com/a/32184137/878361

    but, I'm not sure about the command I must write. Here is a file result of the locate command : [url]http://www.sendbox.fr/f23c0483a0db79cd/testSeekLibgl.txt[/url]

    Can you confirm the command to write is, for me :
    sudo ln -s /usr/lib/x86_64-linux-gnu/libGLU.so.1 /usr/lib/libGL.so

    Another point. Now I have multiple Gcc versions. Which one is the best (more polyvalent) ? ![alt text](0_1517560660326_Capture d’écran de 2018-02-02 09-31-49.png image url)

    Thanks again


  • Moderators

    @Kontiki Install libglu1-mesa-dev package, no need to creaty any symbolic links.
    For more details see http://wiki.qt.io/Building_Qt_5_from_Git



  • Yesss... It works now.

    Thanks so much.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.