If I configure Qt 5.10 for a build on Windows



  • using latest source package from downloads page:

    configure.bat -openssl -L C:\OpenSSL-Win64\lib -I C:\OpenSSL-Win64\include -confirm-license -commercial -prefix c:\QTBUILD\results -release -opengl dynamic -nomake examples -nomake tests

    I don't see any mention of QtWebEngine in the config output - I expected to see mention that QtWebEngine was enabled/available/something.

    When I then nmake to build Qt - Qt builds just fine - but no QtWebEngine.

    I didn't receive errors of any kind during config, I didn't receive errors of any kind during the build.

    Now, when I try to manually trigger a QtWebEngine build by calling qmake directory and pointing it to the QtWebEngine source in the 5.10 source directory - I get a miniature config output that's all about QtWebEngine.

    At this point I can call nmake and away it goes. It's still building now - and presumably will for a long time.

    I may be wrong, but I swear that a 5.10 source package I pulled down just three weeks ago worked differently - the base Qt config mentioned QtWebEngine... Am I missing something obvious or just misremembering?

    Thanks :)



  • Well, it spent 2 hours building, no errors, and no QtWebEngine...
    Apparently, even though the output looks the same as when you use configure.bat, you can't call nmake the same way.
    I guess that just borked the Qt shadow build directory.

    So, now I've moved back into the source directory (assuming that shadow builds either don't work for QtWebEngine - or I'm not doing it right by trying to do it like the rest of Qt) and trying to use qmake directly via "qmake -r"

    Anyone built QtWebEngine on Windows recently?


  • Lifetime Qt Champion

    Hi,

    Not tried but you should add the -voption to see what is happening with QtWebEngine.

    By the way, what compiler are you using ?



  • @SGaist vs 2015 update 3 (QtWebEngine specifies it requires this at a minimum.)

    It looks like I'm building QtWebEngine now (previously it looked like dependencies but I believe it was actually just rebuilding part of the regular Qt Framework.) Chromium is building this time.



  • It appears that you must, and I'm guessing here, build Qt without a shadow build BEFORE you attempt to build QtWebEngine.

    The build just broke stating:

    Reading C:/QTBUILD/qt-everywhere-src-5.10.0/qtwebengine/src/core/core.pro
    Reading C:/QTBUILD/qt-everywhere-src-5.10.0/qtwebengine/src/core/core_headers.pro
    Reading C:/QTBUILD/qt-everywhere-src-5.10.0/qtwebengine/src/core/core_generator.pro
    Project ERROR: Unknown module(s) in QT: qml quick webchannel

    I'm going to go ahead, pollute my source directory with the qt build, and try again...



  • Well, interestingly enough - when not using a shadow build directory, configure reports on QtWebEngine:

    Qt WebEngine:
    Embedded build ......................... no
    Pepper Plugins ......................... yes
    Printing and PDF ....................... yes
    Proprietary Codecs ..................... no
    Spellchecker ........................... yes
    Native Spellchecker .................... no
    WebRTC ................................. yes
    Use System Ninja ....................... no
    Geolocation ............................ yes

    Note: No wayland-egl support detected. Cross-toolkit compatibility disabled.

    Qt is now configured for building. Just run 'nmake'.
    Once everything is built, you must run 'nmake install'.
    Qt will be installed into 'c:\QTBUILD\results'.

    Prior to reconfiguration, make sure you remove any leftovers from
    the previous build.


  • Lifetime Qt Champion

    That's surprising. Did you re-call configure in the same folder without cleanup ? That's a thing to avoid, you might have leftovers from prior trial that might wreak havoc.



  • I did not, I've only previously called configure from my shadow build directory.
    BTW, I've tried the various 'clean' methods people mention but none actually clean the configuration - I either have to delete the shadow build directory or - if I'm not building in a shadow directory - blow away and recopy the source directory.

    Since it appears you cannot build QtWebEngine with Qt from a shadow directory, I'm not building in the source directory itself.


  • Lifetime Qt Champion

    I wonder it is something like QTBUG-44002.



  • I suspect it's due to the complexity of manipulating chromium and its dependencies outside of the the source directory due to either rapidity of change or it being 'build system tech debt' - but I'm just speculating.

    It wouldn't be the end of the world except I can't seem to find out the particular steps to build QtWebEngine... Each failure is likely to require me to replace the source and therefore rebuild all of Qt along the way. This takes a long time (as you would know) before you even get to try building QtWebEngine...


  • Lifetime Qt Champion

    You could also just build the QtWebEngine module using:

    cd qtwebengine
    /path/to/qmake -r
    nmake
    nmake install
    

    You should also consider replacing nmake by jom. It should paralelize the build better.



  • If it doesn't build by default this time, that's what I'm going to do. Thx



  • I believe it succeeded. I'll validate, and then I think I'm going to update the wiki :).


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.