QtCreator Ubuntu 16.04 Offline Installation Issue



  • I am trying to install QtCreator with QtCharts (and possible other packages), but I can't seem to get the widgets to appear in my designer. During the installation I selected all the check boxes (getting the notification that the installation will use ~3.5GB), then continue with the install. No problems. But when I run QtCreator and open a new project, I don't have the QtCharts widget at all. Adding QT += core gui charts to the .pro file results in an error when I try to build. If I attempt to add an #include <QtCharts> it doesn't have an auto-fill option available (other Qt packages are visible, just no charts). If I use the Maintenance tool, it shows all the packages as installed. All of the packages are visible in the /5.10.0/Src/ folder, but nothing seems to be getting linked to the QtCreator IDE. Any suggestions?


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Did you re-run qmake after adding charts to the QT variable ?



  • I've cleaned and rebuilt the project (or tried to) in the IDE, and that's when I get the errors. Do I need to run qmake outside of QtCreator?


  • Lifetime Qt Champion

    No you don't.

    Might be a silly question but did you check that you are using the correct kit to build your application ?



  • I have 4 listed due to some previously installed versions, but I was using the 5.10.0 kit. I started browsing through folders and came across the Configure script in the /5.10.0/Src folder (the folder that contains all the add-on modules), so I'm currently doing a make install with that. No clue if it will help, but worst case I simply wipe the folder and start fresh with a reinstall.


  • Lifetime Qt Champion

    You shouldn't need to do that. Unless you compile Qt yourself ?



  • I didn't compile QtCreator myself (just downloaded the .run file from the main website), but the install script seems to be missing a step. I've looked through the installation log and don't see any errors in there, but I'm not exactly sure if that means anything.


  • Lifetime Qt Champion

    Do you have the logs ?



  • This post is deleted!


  • I do, but the firewall here isn't cooperating.



  • I've tinkered around a bit more and found that I can't even compile the modules from source. Qmake works, but when I try to do a make I get various errors. Qtbase compiles fine, though. I'm wondering if having previously installed QtCreator from the Ubuntu repositories has caused these issues.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.