Unable to launch qt creator on windows 10 64 bit machine



  • Hello All,

    Till yesterday everything was working fine and i was able to use qt using qt creator.
    Today it stopped working and i am not able to start my qt creator after double click on the exe file.
    I tried reinstalling qt but of no use.
    Today i tried to build open cv source code and i have also installed visual studio community edition 2017 along side it.
    Please let me know in case of any issue.

    Regards,
    Satyam


  • Moderators

    @Kira Most probably graphics driver. Try to start QtCreator with "-noload Welcome -noload QmlProfiler -noload QuickDesigner" parameters.



  • @jsulm said in Unable to launch qt creator on windows 10 64 bit machine:

    -noload Welcome -noload QmlProfiler -noload QuickDesigner

    @jsulm : thanks for the reply my qt creator started with qtcreator.exe -noload Welcome -noload QmlProfiler

    1. The graphic of the qtcreator is very low, is there a solution to the problem when to start the qt creator.
    2. I am also facing some issues like:
      I am unable to uninstall the qt application from the control panel. The uninstall program stops with an error of window Maintenance tool.exe have stopped working. Where as there is no problem with other applications.
    3. While building and running the sample app i am getting an error message:
      18:04:10: The process "C:\Qt\Qt5.8.0\Tools\QtCreator\bin\jom.exe" exited with code 2.
      Error while building/deploying project test (kit: Desktop Qt 5.8.0 MSVC2015_64bit)
      When executing step "Make"


  • Hi @Kira

    This seems extreme, but have you looked at removing the settings from <USER>\AppData\Roaming\QtProject? This happened to me twice where QtCreator crashing after installing M$VC (I usually use MinGW) and by removing that folder QtCreator ran, regenerated what it needs, and was fine.

    Just remember to backup the folder before you delete it!



  • @Kira said in Unable to launch qt creator on windows 10 64 bit machine:

    Today it stopped working and i am not able to start my qt creator after double click on the exe file.

    You may need to think what could have changed in your machine. Maybe it's not Qt itself, but the graphics driver for instance.


  • Moderators

    @Kira

    1. Is it same for other Qt applications (you can try VLC media player for example)?
    2. Do you have any anti virus application running? If so try to disable it first.
    3. You need to post the actual error/errors. They are before the lines you posted.


  • @Buckwheat : I have installed MSVC 2015 from the very starting point. But it was working fine at that time.

    @Pablo-J-Rogina : As i remember it was working fine till the point i integrated it with the qt vs tool in visual studio 2017 64-bit Windows 10.
    Later i tried to build opencv from source using visual studio 2017 community edition. So i downloaded cmake using one of the tutorial mentioned online. During compile time cmake asked for some qt files and later i build the opencv program in visual studio.
    I made some changes in visual studio settings as opencv program was not able to start due to version mismatch between 32 bit and 64 bit respectively.
    So I made changes in the linker and other dependencies could it be the probable reason of code not working as qt vs tool is linked to current qt (MSVC2015) 64-bit.

    @jsulm :
    I tried disabling the antivirus but has no effect.
    As far as error is concerned i only i get a window prompt before the application which states that:

    "Setting up environment for Qt usage...
    Remember to call vcvarsall.bat to complete environment setup!
    C:\Qt\Qt5.8.0\5.8\msvc2015_64> "

    I tried running the bat file from visual studio and ran the qt creator but is of no use.

    My one of the concern is whether i will be use the existing compiled open cv files with minGW or will i have to compile all over again.
    The basic purpose of using msvc2015 compiler was to keep the compiler same around opencv, qt and visual studio 2017


  • Moderators

    @Kira You should check your Kit in QtCreator: do you see any warnings/error there?



  • This post is deleted!


  • Thanks everyone for your time. I found the issue it was related to my antivirus program
    Which was also mentioned in one of the threads to disable the antivirus.

    Earlier i had disabled rights of the antivirus to make changes to the file so it was not working;
    So later i completely disabled the antivirus and every thing started working fine right from uninstalling of the application to building of program and qt creator also started working fine.

    Please let me know how to keep the application running along with the antivirus on. And the reason why the antivirus is targeting only the qt application


  • Moderators

    @Kira Depending on your anti virus program you can add exceptions there. Why it is targeting QtCreator? Well, false positive I would say.



  • @jsulm: ok & thanks
    Thanks everyone


  • Qt Champions 2017

    @Kira So please mark this thread as solved now.

    Thanks for your feedback.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.