Doesn't show OpenGL in Android



  • Hi!
    I have a widget app that runs correctly in my computer (MacOS).
    The widget has an openglwidget and I render some objects there. The objects are loaded from a .obj file.

    When I run my app in my Android phone, it just appears some black lines...and I have no idea why is that.. if I am using functions that are not compatible with Android or if it is deprecated or what.
    Can someone help me?



  • Not all devices can run OpenGL properly. Have you tried another device?



  • Hi! Thank you for answering!
    Yes, I have tried different devices and neither of them shows correctly... I don't know what could be wrong


  • Qt Champions 2016

    Hi
    Can it be whatever you are using to load the OBJ files?
    Have you tried drawing something natively ?



  • Hi @mrjj, I'm not sure what you mean by draw natively? Can you tell me an example?


  • Qt Champions 2016

    @Carolinabustillo
    Hi, maybe im just using wrong words.
    it sounds like you load OBJ file and draws that.
    To test its not the loading/OBJ part, i was wondering to draw a line
    or something else simple to see if that shows up.
    (as in the opengl view is active)



  • @mrjj Hi! I tried what you suggested and It works, then I have tried uploading the app in different android versions and in version 4.3 It shows something, it isn't the correct view but it is something. When you build an app in an android device do you have to copy the .obj files or just having them in your .qrc works?


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.