3D Modules not found

  • I am getting the message ":-1: error: Unknown module(s) in QT: 3dcore 3drender 3dinput 3dextras 3dlogic".

    I have QT += 3dcore 3drender 3dinput 3dextras in .pro.

    What do I need to do?

  • @ofmrew
    Did you try to add also "3dlogic" in your .pro file?

  • @Stoyan said in 3D Modules not found:


    Yes, Same result. I also deleted the build directory in between changes. The 3D examples work OK. Is there something in the .pri files of the examples that I need?

  • Let me add that I am using 5.10 on Linux Mint.

  • Lifetime Qt Champion


    Are you getting that message on the console ?
    If so, how are you calling qmake ?
    If not using the full path, then you are likely using the one from your distribution which is not what you want.

  • @SGaist I used QtCreator to create a console application and copied parts of an example. The I run build and the message appears in the General Messages window. I do not know how qmake is being called. Every application that I created to now just compiled; this is my first problem of this sort.

    Why is Qt 3D different?

  • Lifetime Qt Champion

    If it's through Qt Creator then it's the one from your kit that is called. Then I'd check if your kit is really using Qt 5.10. If that's the case, check in your installation folder whether you find the Qt3DXXX libraries. If that's not the case, then start the MaintenanceTool to see if you missed something during installation.

  • @SGaist I have a problem! All updates have been by the maintenance tool. The system information shows:
    Qt 5.10.0 (x86_64-little_endian-lp64 shared (dynamic) release build; by GCC 5.3.1 20160406 (Red Hat 5.3.1-6)) on "xcb"
    OS: Ubuntu 16.04 LTS [linux version 4.4.0-21-generic]

    Architecture: x86_64; features: SSE2 SSE3 SSSE3 SSE4.1 SSE4.2 AVX AVX2 RTM HLE

    However, when I look at the kits, they show 5.9.

    How can I get everything in synch?
    One other question is why do the examples work. Are they not compiled by the same Kits?

  • Lifetime Qt Champion

    Then create a new kit for your 5.10 Qt.

  • @SGaist The problem is that I do not have a QT/5.10 folder, only QT/5.9. Does the maintenance tool actual update QT to a new version or do I need to do something? How do I verify that it is actually using 5.10?

  • @ofmrew I was looking in the wrong place for the version being used. When I went to Tools>Options>Build&Run, I found that Qt version 5.5.1 for Desktop. Is there a way to force automatic updating to the latest version?

  • @ofmrew Let me add some more. I have a folder Qt and in that folder there is a 5.9 folder and in that folder there is gcc_64/include that contains the Qt3DXXX. In Tools>Options>Build&Run>Kits the first line is a yellow triangle Qt 5.5.1 in PATH (qt5) /usr/lib/x86_64-linua-gnu/qt5/bin/qmake. But there is a line that point to /Qt/5.9/gcc_64/bin/qmake, which is correct. Of the three button Add, Remove and Clean Up only Add is active. I believe that the first line should be removed, but how? I also have folders 5.7.0 and 5.8.0 at the same level as the Qt folder.

  • Problem solved. The Kit pointed to the 5.5.1 Qt version.

Log in to reply

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.