Help for configuring CDB.exe for Qt Creator Windows Debugging



  • Hello, I'm Matthew, a newbie to Qt5. I just started the chart example to run this application on both Ubuntu 16 and Windows 10.
    I have installed Qt5.9.3 on my 64-bit Windows 10 machine. The 32-bit Visual Studio 2017 is also installed on this Windows machine.

    Lastly, WDK for Windows 10 (version 1709) is installed. The directory for the installed CDB is

    C:\Program Files (x86)\Windows Kits\10\Debuggers\x64\cdb.exe

    The Desktop Qt 5.9.3 MinGW 32-bit configuration was debuggable.

    Whereas the Desktop Qt 5.9.3 MSVC 64-bit shows the below message when I press the debug button;

    Unknown debugger type "No engine"
    Unable to create a debugging engine of the type "No engine"

    0_1512452540264_NoEngine.png

    I have read about Qt's wiki page (Qt Creator Windows Debugging).

    When I press the RUN button, the application shows the charts.

    The WIN64 preprocessor also works; I made the title change depending on the OS.

    Although I have configured the CDB manually, I cannot debug this project.

    Wiki quote; The 32bit version of cdb.exe can only debug 32bit executables.

    Debuggers\x64\cdb.exe, so I configured the 64-bit CDB. However, the debug session doesn't show up.

    Can you help me with my Windows debugging configuration?

    -Best Regards, Matthew


  • Moderators

    @MATTK The path in "Path:" looks strange.



  • @jsulm Thanks for your reply.

    I have typed
    C:\Program Files (x86)\Windows Kits\10\Debuggers\x64\cdb.exe
    in the "Path".

    Do you mean I should type something else, or is the space (Windows Kits) a problem?

    -Best Regards


  • Moderators

    @MATTK No, in the screen-shot you can see strange character instead of \



  • @jsulm Aha! That is the WON (Korean Bill) sign.

    I'm currently on a business trip in Seoul.

    When using Koren versioned Windows 10, the backslash is typed as the WON sign.

    Wiki quote; the code point 0x5C that would be used for backslash in ASCII is instead rendered as a yen mark (¥), while in Korean encoding, it is drawn as a won currency symbol (₩).

    Sorry for the confusion. Anyways, although it is shown as a different mark, Windows interpret that sign as the backslash.

    Considering this fact, is my CDB path invalid?

    Or should I change the backslash to slash?

    -Best Regards



  • @jsulm
    Hello, jsulm! I have explained about the strange W looking characters.

    Can you help me out with this? I'm new to both Qt5 and the Qt forum.
    Can I ask help to other moderators like you?

    -Best Regards


  • Moderators

    @MATTK Please don't ask directly moderators.
    Did you check http://doc.qt.io/qtcreator/creator-debugger-engines.html ?
    Can you call cdb.exe directly in a terminal?
    Did you configure the correct debugger in your Kit?



  • @jsulm Oh! Thanks a million.

    Thanks for your link,
    0_1513058818194_Path.png

    I didn't add the symbol path. I only configured the "Build & Run" option. Silly me :D

    0_1513058856467_CMDTest.png

    As expected, the CDB.exe can be called directly in the CMD terminal.

    Thanks for your time!

    -Best Regards


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.