qwindowcompositor failed to compile with qtcreator



  • Hi,
    New to Qt, I'm searching a framework to start creating a simple window manager. I want to try qwindowcompositor and expand/modify it with qtcreator but, if pure-qml compile nicely, qwindow doesn't want at all.
    I get the unknown module with waylandcompositor-private.
    And if I remove it, the next error is a wayland-server librarie not define.
    Do someone has a clue?



  • I use a debian distro and I did only install using apt.
    Qt Creator 4.3.1
    Basé sur Qt 5.9.1 (GCC 7.2.0, 64 bit)
    I installed all dev package I could find related to the subject. I am starting to wonder if I import the project the right way.


  • Lifetime Qt Champion

    Hi and welcome to devnet,

    Which version of Qt are you currently using ?
    What packages did you install exactly ?



  • Hi. Thanks for the help.
    I cleaned up all my installed package and I'm currently installing everything from git (master or dev depending on the sources).
    All in the same directory from wayland and dependencies to full qt5 (dev) and qt-creator git. I already tried weston on tty2 and it worked pretty well on top on wayland. I built qt5 nicely but realised that examples didn't. I still have to build qt-creator.
    When I did it with debian package, it was the actual but I didn't check. 5.9.1 for qt and maybe 4.3 for qt-creator and 3.1 for qmake.
    I am sorry, I won't be able to test anything since I cleaned up all.
    Best regards



  • So I finally did it.
    In both case (from repo & sources), I had qmake 3.1 but I think , somehow, qmake wasn't able to find qtwayland library (which was installed). By compiling qt5 myself, including qmake and all the submodules (I did it wildly), everything is connected.
    Maybe I could have done it by adjusting VARIABLES like QT_HOST_LIBS or QT_INSTALL_HEADERS to point where qtwayland was installed but I didn't found how at the moment.
    I solved my problem but can't tell what was the original issue with the repo package.
    Thanks anyway.
    So long.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.