Android APK signing no longer working



  • Hi,

    I can no longer sign APK packages in Windows with Qt 5.9.2, which is probably related to me updating Android Studio and its components recently.

    I get the following error at the end of the build:

    Die Syntax fr den Dateinamen, Verzeichnisnamen oder die Datentr„gerbezeichnung ist falsch.
    apksigner command failed.
      -- Run with --verbose for more information.
    15:33:58: The process "C:\Qt\5.9.2\android_armv7\bin\androiddeployqt.exe" exited with code 15.
    Error while building/deploying project my_app (kit: Android for armeabi-v7a (GCC 4.9, Qt 5.9.2 for Android armv7))
    When executing step "Build Android APK"
    

    First line says 'The syntax for the file name, path name or volume is incorrect', but it does not say what file it is referring to.

    I have tried running androiddeployqt.exe manually using --verbose but did not get any more specific output on this.

    This has worked for me only a few days ago but now fails for all my projects.

    Can anyone confirm if this is only me or a general problem with the latest Android Studio?


  • Lifetime Qt Champion

    Hi,

    Sorry I can't, however you should add what version of the NDK and SDK you have now on your system.



  • NDK version: r12b
    SDK version: 24

    However I have been using these for a while and signing has always worked for me before. I can still sign packages manually using apksigner directly, but it fails when using androiddeployqt.exe. The only thing I can think of that has changed is that Android Studio ran a lot of automatic updates, but I don't remember what exactly has been updated.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.