Qt5 wont open on Raspberry Pi3 with Raspbian



  • I cant open Qt Creator on Raspbian. I used the normal raspbian repository to install qt5, should i maybe install it from source? Actually it opens but it just shows the frame of the window and not much more. My errormessage when i open qt creator with terminal is:

    ** (qtcreator:17902): WARNING **: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
    JIT is disabled for QML. Property bindings and animations will be very slow. Visit https://wiki.qt.io/V4 to learn about possible solutions for your platform.
    JIT is disabled for QML. Property bindings and animations will be very slow. Visit https://wiki.qt.io/V4 to learn about possible solutions for your platform.
    JIT is disabled for QML. Property bindings and animations will be very slow. Visit https://wiki.qt.io/V4 to learn about possible solutions for your platform.
    JIT is disabled for QML. Property bindings and animations will be very slow. Visit https://wiki.qt.io/V4 to learn about possible solutions for your platform.
    "Das Kommando \"/qmake\" konnte nicht gestartet werden."
    No tool chain set from kit "Desktop".
    No tool chain set from kit "Desktop".
    No tool chain set from kit "Desktop".
    No tool chain set from kit "Desktop".
    QEGLPlatformContext: eglMakeCurrent failed: 3009
    composeAndFlush: makeCurrent() failed
    QEGLPlatformContext: eglMakeCurrent failed: 3009
    composeAndFlush: makeCurrent() failed
    QEGLPlatformContext: eglMakeCurrent failed: 3009
    composeAndFlush: makeCurrent() failed
    QEGLPlatformContext: eglMakeCurrent failed: 3009
    composeAndFlush: makeCurrent() failed
    QQuickWidget: Attempted to render scene with no context
    

    I cant get much out of this error so i really dont know what to do. Can someone help me?


  • Moderators

    @Xenoshell This is something already asked many times here.
    Try to start QtCreator with "-noload Welcome" parameter. If it starts then disable Welcome plug-in the plug-in settings.
    You can try "-noload QmlProfiler -noload QuickDesigner" as well if disabling Welcome doesn't help.
    See http://doc.qt.io/qtcreator/creator-faq.html



  • @jsulm, yeah i saw those threads. Its just that they didnt had a solution for me. Strangely "sudo qtcreator -noload Welcome" doesnt work but "qtcreator -noload Welcome" does. I still get this as error:

    ** (qtcreator:5646): WARNING **: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
    JIT is disabled for QML. Property bindings and animations will be very slow. Visit https://wiki.qt.io/V4 to learn about possible solutions for your platform.
    JIT is disabled for QML. Property bindings and animations will be very slow. Visit https://wiki.qt.io/V4 to learn about possible solutions for your platform.
    JIT is disabled for QML. Property bindings and animations will be very slow. Visit https://wiki.qt.io/V4 to learn about possible solutions for your platform.
    "Das Kommando \"/qmake\" konnte nicht gestartet werden."
    No tool chain set from kit "Desktop".
    No tool chain set from kit "Desktop".
    No tool chain set from kit "Desktop".
    No tool chain set from kit "Desktop".
    

    I just hope it works like that


  • Moderators

    @Xenoshell Why do you need sudo?!



  • @jsulm ok maybe you dont need it but sometimes it can help if a command has some special requirements, right? I know that sudo allows the command to do anything it wants to do so it shouldnt be that wrong if I just want to open a program.



  • @Xenoshell said in Qt5 wont open on Raspberry Pi3 with Raspbian:

    @jsulm ok maybe you dont need it but sometimes it can help if a command has some special requirements, right? I know that sudo allows the command to do anything it wants to do so it shouldnt be that wrong if I just want to open a program.

    If you use sudo like that, you'll get the same security problems as in Windows on your Linux box.

    Further hint: after you started QtCreator with sudo it might have changed the permissions of some configuration files so you might get problems when running again without sudo. For me, these configuration files are in ~/.config/QtProject/


  • Moderators

    @Xenoshell If a command/tool needs root rights it is better to set http://linuxg.net/how-to-set-the-setuid-and-setgid-bit-for-files-in-linux-and-unix/ instead of running whole IDE as root! I never saw a need to run an IDE as root and I'm software developer for quite some time.


Log in to reply
 

Looks like your connection to Qt Forum was lost, please wait while we try to reconnect.